summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.31.0.ebuild172
2 files changed, 175 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 2b17be259b31..f440c1c61ab5 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,3 +1,6 @@
DIST kitty-0.30.1-vendor.tar.xz 1425096 BLAKE2B dcf65787badf2439b5e7dc9ff1fb2073d0d8b124a7c39e017aee70a9c5c8f9b5f75b9c7942748cdd7327c75e506d667736eb13d91d8c42f46dfff12ffb9ae4d9 SHA512 4cabb39c82b4dfde96390bfd739d24af3abc6a48f2f6013fb51a1d95d31b04c545f8dbf0d3fc89bcb692c26955bdefe196e95d41eed7222eb815b3f05688a362
DIST kitty-0.30.1.tar.xz 7799076 BLAKE2B 99ada03fa957819e716d3225fbee20af62135ff8861d3a6ce8aaf442b4526a69f34dae0ec126db48a4336fcbd2dfde5583e2ff8f16140e938fada6c0a8854a60 SHA512 e5fd68b8acf3eae8f53a2c27101d998eb0d8eff1571de1b03ab431bceafcab0efae821590684ec48b5ed6e3d86fb984d9e04784022ba50c0378d37a68598f9ed
DIST kitty-0.30.1.tar.xz.sig 566 BLAKE2B 18ad4df3ef3e161d8382f635f371b0100ff812d3eb2d5d1a2af1df2e04d1c15a344e4dd86d6a8faaf663a6a9d579521cdacdf6c5b1852d2120d94c43cd765826 SHA512 8c90733cb1683f6cb7c57fcf1efdbd0a99b16c4e1edca9b7e99820e5108694fcee521fecd7adaecc331a744b04d2041594adbf058d6218cd82099550f04b961e
+DIST kitty-0.31.0-vendor.tar.xz 1397172 BLAKE2B 0c3bf3cece86cec651ec6dd4a97923464636885e5c9ef44b0e094d34ea66ca1b8176cc7d2647eda0030f857faf5e87e506ec9af6465487ef9a61efd634492d86 SHA512 41699cbd112f429d78dbf5b7716b3b017d5decd3649a13913e273a5b1ab6177ab7d93c5d2e3cb9b927846f41ada91f8cf95e7148e52d6a3bf914e7b116b7b072
+DIST kitty-0.31.0.tar.xz 7929620 BLAKE2B 74ccd0e14803ee3991d895c8ec0099567b6a087110eda03d5b35a45d1e684916d63846f1bd1184b2f5fe7a88431983602899cfd6392c28de78d020b8c98c89b2 SHA512 3868431003f9f1a3907415124c1d8282b077985a9d104615d48f9d309f6fbf1a11119546674508649aa35f2b6e66aa5638024e8127f92ae7b043da367c7b3363
+DIST kitty-0.31.0.tar.xz.sig 566 BLAKE2B 5013b35dd7119b5bed3e4fefee70009f6fe6ba8c3215a35e82fdd3929063ef32c58c77f12c246374693801936ac362c3d432da95c91b632fdb848d98b3cf0bf9 SHA512 cc8583bbdd9e23a005cecb87f5d7d72ada5db1a1a8cdf59a67a103fc0c11df403df2673434d373216415903b6967a1638bf3f51ff7474368d618685a542d4280
diff --git a/x11-terms/kitty/kitty-0.31.0.ebuild b/x11-terms/kitty/kitty-0.31.0.ebuild
new file mode 100644
index 000000000000..9090e9ba7a22
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.31.0.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.21
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}