summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/updates/3Q-20171
-rw-r--r--sys-devel/llvm-common/Manifest (renamed from app-vim/llvm-vim/Manifest)0
-rw-r--r--sys-devel/llvm-common/llvm-common-4.0.0.ebuild (renamed from app-vim/llvm-vim/llvm-vim-4.0.0.ebuild)13
-rw-r--r--sys-devel/llvm-common/llvm-common-4.0.1.ebuild (renamed from app-vim/llvm-vim/llvm-vim-4.0.1.ebuild)13
-rw-r--r--sys-devel/llvm-common/llvm-common-9999.ebuild (renamed from app-vim/llvm-vim/llvm-vim-9999.ebuild)11
-rw-r--r--sys-devel/llvm-common/metadata.xml (renamed from app-vim/llvm-vim/metadata.xml)0
-rw-r--r--sys-devel/llvm/llvm-4.0.0-r2.ebuild2
-rw-r--r--sys-devel/llvm/llvm-4.0.1.ebuild2
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild2
9 files changed, 29 insertions, 15 deletions
diff --git a/profiles/updates/3Q-2017 b/profiles/updates/3Q-2017
new file mode 100644
index 000000000000..a7574b919eef
--- /dev/null
+++ b/profiles/updates/3Q-2017
@@ -0,0 +1 @@
+move app-vim/llvm-vim sys-devel/llvm-common
diff --git a/app-vim/llvm-vim/Manifest b/sys-devel/llvm-common/Manifest
index a0a5bf2ee812..a0a5bf2ee812 100644
--- a/app-vim/llvm-vim/Manifest
+++ b/sys-devel/llvm-common/Manifest
diff --git a/app-vim/llvm-vim/llvm-vim-4.0.0.ebuild b/sys-devel/llvm-common/llvm-common-4.0.0.ebuild
index bd68c2ceeccb..d307094d751b 100644
--- a/app-vim/llvm-vim/llvm-vim-4.0.0.ebuild
+++ b/sys-devel/llvm-common/llvm-common-4.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-DESCRIPTION="Vim support files for LLVM"
+DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="http://llvm.org/"
SRC_URI="http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
@@ -14,11 +14,16 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
-S=${WORKDIR}/llvm-${PV/_/}.src/utils/vim
+S=${WORKDIR}/llvm-${PV/_/}.src
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r */
+ doins -r utils/vim/*/
# some users may find it useful
- dodoc README vimrc
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
}
diff --git a/app-vim/llvm-vim/llvm-vim-4.0.1.ebuild b/sys-devel/llvm-common/llvm-common-4.0.1.ebuild
index bd68c2ceeccb..d307094d751b 100644
--- a/app-vim/llvm-vim/llvm-vim-4.0.1.ebuild
+++ b/sys-devel/llvm-common/llvm-common-4.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-DESCRIPTION="Vim support files for LLVM"
+DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="http://llvm.org/"
SRC_URI="http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
@@ -14,11 +14,16 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
-S=${WORKDIR}/llvm-${PV/_/}.src/utils/vim
+S=${WORKDIR}/llvm-${PV/_/}.src
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r */
+ doins -r utils/vim/*/
# some users may find it useful
- dodoc README vimrc
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
}
diff --git a/app-vim/llvm-vim/llvm-vim-9999.ebuild b/sys-devel/llvm-common/llvm-common-9999.ebuild
index 0ac1dde4ca84..75124672bd72 100644
--- a/app-vim/llvm-vim/llvm-vim-9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit git-r3
-DESCRIPTION="Vim support files for LLVM"
+DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="http://llvm.org/"
SRC_URI=""
EGIT_REPO_URI="http://llvm.org/git/llvm.git
@@ -18,11 +18,14 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
-S=${WORKDIR}/${P}/utils/vim
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r */
+ doins -r utils/vim/*/
# some users may find it useful
- dodoc README vimrc
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
}
diff --git a/app-vim/llvm-vim/metadata.xml b/sys-devel/llvm-common/metadata.xml
index 89c4bdb96049..89c4bdb96049 100644
--- a/app-vim/llvm-vim/metadata.xml
+++ b/sys-devel/llvm-common/metadata.xml
diff --git a/sys-devel/llvm/llvm-4.0.0-r2.ebuild b/sys-devel/llvm/llvm-4.0.0-r2.ebuild
index e599e21fc6e1..0ffd1b669de2 100644
--- a/sys-devel/llvm/llvm-4.0.0-r2.ebuild
+++ b/sys-devel/llvm/llvm-4.0.0-r2.ebuild
@@ -60,7 +60,7 @@ DEPEND="${RDEPEND}
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
-PDEPEND="app-vim/llvm-vim
+PDEPEND="sys-devel/llvm-common
gold? ( sys-devel/llvmgold )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
diff --git a/sys-devel/llvm/llvm-4.0.1.ebuild b/sys-devel/llvm/llvm-4.0.1.ebuild
index 6c93c3a8f1b1..e0f1f16e0ff6 100644
--- a/sys-devel/llvm/llvm-4.0.1.ebuild
+++ b/sys-devel/llvm/llvm-4.0.1.ebuild
@@ -60,7 +60,7 @@ DEPEND="${RDEPEND}
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
-PDEPEND="app-vim/llvm-vim
+PDEPEND="sys-devel/llvm-common
gold? ( sys-devel/llvmgold )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 99121e917a09..daa98381996b 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -61,7 +61,7 @@ DEPEND="${RDEPEND}
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
-PDEPEND="app-vim/llvm-vim
+PDEPEND="sys-devel/llvm-common
gold? ( sys-devel/llvmgold )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}