summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild38
-rw-r--r--dev-perl/DateTime-TimeZone/Manifest1
-rw-r--r--dev-perl/DateTime-TimeZone/metadata.xml5
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild b/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild
new file mode 100644
index 000000000000..f714ff1ce95b
--- /dev/null
+++ b/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=2.39
+inherit perl-module
+
+DESCRIPTION="Time zone object base class and factory"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Class-Singleton-1.30.0
+ >=virtual/perl-File-Spec-3.0.0
+ dev-perl/Module-Runtime
+ >=dev-perl/Params-ValidationCompiler-0.130.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=dev-perl/Specio-0.150.0
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Path
+ virtual/perl-File-Temp
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/DateTime-TimeZone/Manifest b/dev-perl/DateTime-TimeZone/Manifest
index d151b748db90..e7382fb97293 100644
--- a/dev-perl/DateTime-TimeZone/Manifest
+++ b/dev-perl/DateTime-TimeZone/Manifest
@@ -3,3 +3,4 @@ DIST DateTime-TimeZone-1.94.tar.gz 898119 BLAKE2B 5643c0d15ccf73109e6ee55db2a05e
DIST DateTime-TimeZone-2.01.tar.gz 929462 BLAKE2B 2a21bbc69e5df5cfb459bfaa93af937d4eec2cea0e20cd14726ee77d62605df320f92647a94357ec763619442a83c5d2ce02cf55f02c46c18b94407ad98bb782 SHA512 57c98bbf25cd0aedb8cae72ea9b15042f75d74c776d125c53bdf487202d7fbb643367be3e0ddfb3080661ecec584e0a08b5ec0854f67bc50321da47a699999cf
DIST DateTime-TimeZone-2.11.tar.gz 954800 BLAKE2B 9a0eeecce85efeb6de4df0d5be237294adcf27fbae6ff77e2707e7386e9c7916280eba6bfc71b53d35bba2f0af8dab9b6c56ff4d25cc78ab2d9a18bd85fb9586 SHA512 558d4cd71569c76c0c4128ecc7a6cff8bd0f2db3b818528fe77a05a9da9eac26edde163b9ddd20cd994c4cc571216594ee2db0214fd3ca8b2aac5888d9c79a47
DIST DateTime-TimeZone-2.13.tar.gz 945446 BLAKE2B cbc715cdea59098c1cb6994a99b93785769b0a97c32260fd2c00a0caa48682cbb0280db02e68e7d9dea97d5a557baa9a37cad86d9518a30a7d760bc0f44447b6 SHA512 6003b2b6044c35a7c75840cf550d1f68500c1d762dc0ebdcf22e1714b68804382d2d969512d183c460fe89fe2fdbd8037463594536d6c3acee0ccf79734ac654
+DIST DateTime-TimeZone-2.39.tar.gz 993595 BLAKE2B 164fd56d2d5296fab711220ae159f0da67a3f6f9761db41c4895206c58e3cc44ea31cf36b844fdd7d9103cd98c018f70b16c14daae867820befd2108693b9356 SHA512 6f7580aa873a66d1892cd9201b5b2efd088842ffc2696e94c59c5532935be7eecea067fa979465046e0eeb35ca34e73bc49006e176445eaed91ac179beacc13b
diff --git a/dev-perl/DateTime-TimeZone/metadata.xml b/dev-perl/DateTime-TimeZone/metadata.xml
index b1c62de8be9b..0274946f9777 100644
--- a/dev-perl/DateTime-TimeZone/metadata.xml
+++ b/dev-perl/DateTime-TimeZone/metadata.xml
@@ -17,12 +17,14 @@
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Ceuta</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::El_Aaiun</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Johannesburg</remote-id>
+ <remote-id type="cpan-module">DateTime::TimeZone::Africa::Juba</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Khartoum</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Lagos</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Maputo</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Monrovia</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Nairobi</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Ndjamena</remote-id>
+ <remote-id type="cpan-module">DateTime::TimeZone::Africa::Sao_Tome</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Tripoli</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Tunis</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Africa::Windhoek</remote-id>
@@ -74,7 +76,6 @@
<remote-id type="cpan-module">DateTime::TimeZone::America::Fort_Nelson</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::Fortaleza</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::Glace_Bay</remote-id>
- <remote-id type="cpan-module">DateTime::TimeZone::America::Godthab</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::Goose_Bay</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::Grand_Turk</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::Guatemala</remote-id>
@@ -122,6 +123,7 @@
<remote-id type="cpan-module">DateTime::TimeZone::America::North_Dakota::Beulah</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::North_Dakota::Center</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::North_Dakota::New_Salem</remote-id>
+ <remote-id type="cpan-module">DateTime::TimeZone::America::Nuuk</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::Ojinaga</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::Panama</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::America::Pangnirtung</remote-id>
@@ -219,6 +221,7 @@
<remote-id type="cpan-module">DateTime::TimeZone::Asia::Pontianak</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Asia::Pyongyang</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Asia::Qatar</remote-id>
+ <remote-id type="cpan-module">DateTime::TimeZone::Asia::Qostanay</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Asia::Qyzylorda</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Asia::Riyadh</remote-id>
<remote-id type="cpan-module">DateTime::TimeZone::Asia::Sakhalin</remote-id>