summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-games/aseprite/Manifest2
-rw-r--r--dev-games/aseprite/aseprite-0.9.5-r1.ebuild4
-rw-r--r--dev-games/aseprite/aseprite-1.1.4.1.ebuild (renamed from dev-games/aseprite/aseprite-1.0.6.ebuild)44
-rw-r--r--dev-games/aseprite/aseprite-9999.ebuild95
-rw-r--r--dev-games/aseprite/files/aseprite-1.0.6-obinary.patch27
-rw-r--r--dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch11
-rw-r--r--dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch12
-rw-r--r--dev-games/aseprite/metadata.xml1
8 files changed, 39 insertions, 157 deletions
diff --git a/dev-games/aseprite/Manifest b/dev-games/aseprite/Manifest
index 00fdc1697cd7..b04c4f000bcb 100644
--- a/dev-games/aseprite/Manifest
+++ b/dev-games/aseprite/Manifest
@@ -1,2 +1,2 @@
+DIST Aseprite-v1.1.4.1-Source.zip 11723085 SHA256 731ac44259217626dde91cdcae9a24cdd4337540fc91bbe5c05cebcb12869879 SHA512 deeb42c123517e17378498584bb788f375e8aaaf046d5f9732848a5bd794a1af1d8381ff51271f9e30c198478e0f716ae23495972b693db9049ff4c2b8968672 WHIRLPOOL 5c2bd1bf8f5d187c385086a431ab070f55308b01089ce703e54093963402a9300295ea1cbf3602021fea1211ae68c6a2a07391e8e054827ce82ee60462001c4a
DIST aseprite-0.9.5.tar.xz 507744 SHA256 81e0360d9d8a32d6c548775dbacdb1520aac94b54c2d9f1327d52f219737f154 SHA512 fc6df942aefea67fd05e1b688209b70a2d5879a1441f61a6e3ee4d72fcdab4e580e1d4d7392fd493e0a46c45401a3eef759aa3efee17450e4c98df7f310b2d00 WHIRLPOOL 060dcf2754827ab3b30dde55cfcecd25e2d88f6e296b45529737e2194f4a9891d171776d10f9c571890efb9766b64080b85dc3d737102d2ac7be9843d27fdaef
-DIST aseprite-1.0.6.tar.gz 3685678 SHA256 449619ee49eaf18c483706c6d2364868085b0f311548bd69e5664fdc0c06e21e SHA512 0189cb6d845ea799f84c17b6456a10341a5ba2a2712bed2c202a711ffe60bb3f2e2eb47bb5702c6326f16a842cd8780c4c1f44ba61111a535b172c34e6f2d327 WHIRLPOOL 4bbf000bf30beafef0003f047f625d4af7e61d51336562ba9192eceb4c72cafbd361bf68ba5fef20b260e74997b679d440d2f9e6386c1ab48c0a6e103577caf2
diff --git a/dev-games/aseprite/aseprite-0.9.5-r1.ebuild b/dev-games/aseprite/aseprite-0.9.5-r1.ebuild
index 1904a989e4e8..9965cf332842 100644
--- a/dev-games/aseprite/aseprite-0.9.5-r1.ebuild
+++ b/dev-games/aseprite/aseprite-0.9.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,7 +22,7 @@ RDEPEND="dev-libs/tinyxml
media-libs/libpng:0
net-misc/curl
sys-libs/zlib
- virtual/jpeg
+ virtual/jpeg:0
x11-libs/libX11"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
diff --git a/dev-games/aseprite/aseprite-1.0.6.ebuild b/dev-games/aseprite/aseprite-1.1.4.1.ebuild
index a701677ca1b1..f89be1161888 100644
--- a/dev-games/aseprite/aseprite-1.0.6.ebuild
+++ b/dev-games/aseprite/aseprite-1.1.4.1.ebuild
@@ -1,36 +1,39 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-inherit cmake-utils multilib toolchain-funcs flag-o-matic
+inherit cmake-utils flag-o-matic
DESCRIPTION="Animated sprite editor & pixel art tool"
HOMEPAGE="http://www.aseprite.org"
-SRC_URI="https://github.com/aseprite/aseprite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/aseprite/aseprite/releases/download/v${PV}/Aseprite-v${PV}-Source.zip"
-LICENSE="GPL-2 FTL"
+# See https://github.com/aseprite/aseprite#credits
+# Some bundled third-party packages built-in:
+# gtest duktape modp_b64 simpleini
+LICENSE="BSD GPL-2 MIT"
SLOT="0"
-# giflib still unkeyworded
-KEYWORDS=""
+KEYWORDS="~amd64 ~x86"
-IUSE="debug memleak"
+IUSE="debug test webp"
RDEPEND="dev-libs/tinyxml
media-libs/allegro:0[X,png]
- >=media-libs/giflib-5.0
+ media-libs/freetype
+ media-libs/giflib
+ webp? ( media-libs/libwebp )
media-libs/libpng:0
+ net-misc/curl
sys-libs/zlib
- virtual/jpeg
+ virtual/jpeg:0
x11-libs/libX11
x11-libs/pixman"
DEPEND="${RDEPEND}
- dev-cpp/gtest"
+ app-arch/unzip"
-PATCHES=( "${FILESDIR}"/aseprite-0.9.5-underlinking.patch
- "${FILESDIR}"/${P}-obinary.patch
- "${FILESDIR}"/${P}-png_sizeof.patch )
+PATCHES=( "${FILESDIR}"/${P}_underlinking.patch )
DOCS=( docs/files/ase.txt
docs/files/fli.txt
@@ -39,6 +42,8 @@ DOCS=( docs/files/ase.txt
docs/files/picpro.txt
README.md )
+S="${WORKDIR}"
+
src_prepare() {
cmake-utils_src_prepare
@@ -46,30 +51,27 @@ src_prepare() {
if use debug ; then
sed -i '/-DNDEBUG/d' CMakeLists.txt || die
fi
-
- rm -r third_party/* || die
}
src_configure() {
use debug && append-cppflags -DDEBUGMODE -D_DEBUG
local mycmakeargs=(
- -DCURL_STATICLIB=OFF
-DENABLE_UPDATER=OFF
-DFULLSCREEN_PLATFORM=ON
- -DLIBPIXMAN_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --variable=includedir pixman-1)/pixman-1"
- -DLIBPIXMAN_LIBRARY="$($(tc-getPKG_CONFIG) --variable=libdir pixman-1)/libpixman-1.so"
-DUSE_SHARED_ALLEGRO4=ON
-DUSE_SHARED_CURL=ON
+ -DUSE_SHARED_FREETYPE=ON
-DUSE_SHARED_GIFLIB=ON
- -DUSE_SHARED_GTEST=ON
-DUSE_SHARED_JPEGLIB=ON
-DUSE_SHARED_LIBLOADPNG=ON
-DUSE_SHARED_LIBPNG=ON
-DUSE_SHARED_PIXMAN=ON
-DUSE_SHARED_TINYXML=ON
-DUSE_SHARED_ZLIB=ON
- $(cmake-utils_use_enable memleak)
+ -DUSE_SHARED_LIBWEBP=ON
+ -DWITH_WEBP_SUPPORT="$(usex webp)"
+ -DENABLE_TESTS="$(usex test)"
)
cmake-utils_src_configure
diff --git a/dev-games/aseprite/aseprite-9999.ebuild b/dev-games/aseprite/aseprite-9999.ebuild
deleted file mode 100644
index 56d269378738..000000000000
--- a/dev-games/aseprite/aseprite-9999.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit cmake-utils flag-o-matic git-2
-
-DESCRIPTION="Animated sprite editor & pixel art tool"
-HOMEPAGE="http://www.aseprite.org"
-EGIT_REPO_URI="git://github.com/dacap/${PN}.git"
-
-LICENSE="GPL-2 FTL"
-SLOT="0"
-KEYWORDS=""
-
-IUSE="debug memleak static test"
-
-RDEPEND="dev-libs/tinyxml
- media-libs/allegro:0[X,png]
- media-libs/giflib
- media-libs/libpng:0
- net-misc/curl
- sys-libs/zlib
- virtual/jpeg
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest )"
-
-DOCS=( docs/quickref.odt
- docs/files/ase.txt
- docs/files/fli.txt
- docs/files/msk.txt
- docs/files/pic.txt
- docs/files/picpro.txt )
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # Fix to make flag-o-matic work.
- if use debug ; then
- sed -i '/-DNDEBUG/d' CMakeLists.txt || die
- fi
-
- # Only do a static link with Allegro if the user explicitly wants it.
- if ! use static ; then
- sed -i '/-DALLEGRO_STATICLINK/d' CMakeLists.txt || die
- fi
-
- # Remove long compiling tests for users with FEATURES="-test",
- # also removes the gtest dependency from the build.
- if ! use test ; then
- sed -i '/^find_unittests/d' src/CMakeLists.txt || die
- sed -i '/include_directories(.*third_party\/gtest.*)/d' src/CMakeLists.txt || die
- sed -i '/add_subdirectory(gtest)/d' third_party/CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- use debug && append-cppflags -DDEBUGMODE -D_DEBUG
-
- local mycmakeargs
-
- mycmakeargs=(
- -DENABLE_UPDATER=OFF
- -DUSE_SHARED_ALLEGRO4=ON
- -DUSE_SHARED_CURL=ON
- -DUSE_SHARED_GIFLIB=ON
- -DUSE_SHARED_JPEGLIB=ON
- -DUSE_SHARED_LIBLOADPNG=ON
- -DUSE_SHARED_LIBPNG=ON
- -DUSE_SHARED_TINYXML=ON
- -DUSE_SHARED_ZLIB=ON
- -DFULLSCREEN_PLATFORM=ON
- $(cmake-utils_use_enable memleak)
- $(cmake-utils_use_use static STATIC_LIBC)
- )
-
- if use test ; then
- mycmakeargs+=(
- -DUSE_SHARED_GTEST=ON
- )
- fi
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- elog "Warning: aseprite might not choose the resolution correctly; so, you might need"
- elog " to change the resolution once using the -resolution WxH[xBPP] argument."
- elog ""
- elog " On subsequent runs, aseprite will remember the resolution you have set."
- elog ""
- elog " For example: \`aseprite -resolution 1440x900\`"
-}
diff --git a/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch b/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch
deleted file mode 100644
index 4536fc53a217..000000000000
--- a/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 9997ad9fcbb0dcef16e4e8224e4238ecdfe56b66 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Matthias=20Mail=C3=A4nder?=
- <Mailaender@users.noreply.github.com>
-Date: Sun, 28 Sep 2014 06:38:18 +0200
-Subject: [PATCH] always declare O_BINARY
-
-closes #461
----
- src/base/file_handle.cpp | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/base/file_handle.cpp b/src/base/file_handle.cpp
-index 0ba214e..f336513 100644
---- a/src/base/file_handle.cpp
-+++ b/src/base/file_handle.cpp
-@@ -21,6 +21,11 @@
- #include <fcntl.h>
- #endif
-
-+#ifndef O_BINARY
-+#define O_BINARY 0
-+#define O_TEXT 0
-+#endif
-+
- using namespace std;
-
- namespace base {
diff --git a/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch b/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch
deleted file mode 100644
index 02fa48006646..000000000000
--- a/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/app/file/png_format.cpp
-+++ src/app/file/png_format.cpp
-@@ -413,7 +413,7 @@
- #endif
-
- // Save the color palette.
-- palette = (png_colorp)png_malloc(png_ptr, PNG_MAX_PALETTE_LENGTH * png_sizeof(png_color));
-+ palette = (png_colorp)png_malloc(png_ptr, PNG_MAX_PALETTE_LENGTH * sizeof(png_color));
- for (c = 0; c < PNG_MAX_PALETTE_LENGTH; c++) {
- fop_sequence_get_color(fop, c, &r, &g, &b);
- palette[c].red = r;
diff --git a/dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch b/dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch
new file mode 100644
index 000000000000..4240040f8f5d
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.1.4.1_underlinking.patch
@@ -0,0 +1,12 @@
+diff --git a/src/she/CMakeLists.txt b/src/she/CMakeLists.txt
+index eddf386..d1b8ce5 100644
+--- a/src/she/CMakeLists.txt
++++ b/src/she/CMakeLists.txt
+@@ -205,6 +205,7 @@ endif()
+ add_library(she ${SHE_SOURCES})
+
+ target_link_libraries(she
++ ${PLATFORM_LIBS}
+ gfx-lib
+ base-lib)
+
diff --git a/dev-games/aseprite/metadata.xml b/dev-games/aseprite/metadata.xml
index c61cf29a6797..21336c442458 100644
--- a/dev-games/aseprite/metadata.xml
+++ b/dev-games/aseprite/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="memleak">Enable memory-leaks detector (only for developers)</flag>
<flag name="static">Link against static version of C and C++ runtimes</flag>
+ <flag name="webp">Enable webp image format support</flag>
</use>
<upstream>
<remote-id type="github">aseprite/aseprite</remote-id>