summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/spake2/Manifest1
-rw-r--r--dev-python/spake2/metadata.xml13
-rw-r--r--dev-python/spake2/spake2-0.8.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/spake2/Manifest b/dev-python/spake2/Manifest
new file mode 100644
index 000000000000..9f81f89fe54b
--- /dev/null
+++ b/dev-python/spake2/Manifest
@@ -0,0 +1 @@
+DIST spake2-0.8.gh.tar.gz 62425 BLAKE2B 64215362af26fff0785fdabf4282f7111a4cc917750827075b616f009cb1fa6373fc2325382c26b43c051aa5b94e414ca2a5223d9ab666289eb2d04723b15cb5 SHA512 908c377c831f4a11551973ca917b113d51a66c533d35fd19b2692fdb7e575ed2a5045d9b632bc55c37b68ad092f01dff5da191e9dfbfb5599b72844788438d68
diff --git a/dev-python/spake2/metadata.xml b/dev-python/spake2/metadata.xml
new file mode 100644
index 000000000000..2041ad286cee
--- /dev/null
+++ b/dev-python/spake2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">spake2</remote-id>
+ <remote-id type="github">warner/python-spake2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/spake2/spake2-0.8.ebuild b/dev-python/spake2/spake2-0.8.ebuild
new file mode 100644
index 000000000000..8fa00484e842
--- /dev/null
+++ b/dev-python/spake2/spake2-0.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="python implementation of SPAKE2 password-authenticated key exchange algorithm"
+HOMEPAGE="https://pypi.org/project/spake2/"
+SRC_URI="https://github.com/warner/python-${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/python-${P}"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/hkdf[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest