summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/sshkit/Manifest3
-rw-r--r--dev-ruby/sshkit/sshkit-1.10.0.ebuild43
-rw-r--r--dev-ruby/sshkit/sshkit-1.11.0.ebuild43
-rw-r--r--dev-ruby/sshkit/sshkit-1.11.1.ebuild43
4 files changed, 0 insertions, 132 deletions
diff --git a/dev-ruby/sshkit/Manifest b/dev-ruby/sshkit/Manifest
index e3fdefa6f85d..6095ebf4863a 100644
--- a/dev-ruby/sshkit/Manifest
+++ b/dev-ruby/sshkit/Manifest
@@ -1,4 +1 @@
-DIST sshkit-1.10.0.gem 144896 SHA256 52be5c07361644f7ab461e14ffd2455a3ee5a7df01b03428bfa3716c830344a4 SHA512 e89a91acd073ccfc73e15eff5c163273c80ef086bfe97e3df3af7b6ee3ce6b425b2bc4d0031526092cb709ec84a4643d3c8719b1341c5e406455dcac5f9e8c91 WHIRLPOOL eb389dd4103df89d1614826cbca0d6a93bc8f8594a264a0cd5916d4097cded107cb61ac180727f9fbda384d3bc0136d466e81af64ea4bc2ce186cc96969b0fea
-DIST sshkit-1.11.0.gem 144896 SHA256 b3917b9ea28e031652391fd8ec1b95212e1413610bb26f8bba78c44767dea279 SHA512 2c6d1f43e34e69224a202bd3322a4bb9c8b583c36bfe967ce121c97bd2966c24283d1c51264221b312776b8ac1266f24e6cef6eef90cca016614c40ea9d7459d WHIRLPOOL 9dae289df030e1d0a7e299977e0a2b6158b2111a98c86485de31bdffac3699be3a5c02f111115083ca3d22242edadb2496a72cc65326972bcc8002a56464b62c
-DIST sshkit-1.11.1.gem 144896 SHA256 7fccc5b73dd992ac21c3453e4f9ddc8bbd48f60ae1e9c4478f093f945ab15178 SHA512 bcf08c14bd5d15e08870379c9bfe388e906ebbad2adc4f395c73d8da3446d9f72223f03236d01d8c43d1965f462eb9d3acabfe0e11e4422675bc2017fd6e4427 WHIRLPOOL 54695eb841ee29a85b78e4d235cc035497b42ae842b8626b411082ec32c08e1617ce58312dc12a21fbdd143e0ceeab8a9e9dcc674842a4025fb5944553fdd775
DIST sshkit-1.11.2.gem 144896 SHA256 610cebe87c1c016693e2d80bb5e5411961a0405358bdba6a6b3f11d682bfc125 SHA512 11dc614eb79967b265732c0ec99ecc35545ec0c083f8693f0596373560ba58e6a7781b285037d81aa0325beadd6fe1c0aa0f1b7a760dbdc32ad6192ecc438dfc WHIRLPOOL d49c18288092b987c5548943e0fa92d64aad21bea9e11384bca06cf935ef26932ac6f830e2b92d06a99b23f774594962eb5fffabb888ab79638c6c389500f339
diff --git a/dev-ruby/sshkit/sshkit-1.10.0.ebuild b/dev-ruby/sshkit/sshkit-1.10.0.ebuild
deleted file mode 100644
index c8ee20de483f..000000000000
--- a/dev-ruby/sshkit/sshkit-1.10.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-# There are functional tests that require vagrant boxes to be set up.
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
-HOMEPAGE="https://github.com/capistrano/sshkit"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/net-ssh-2.8.0:*
- >=dev-ruby/net-scp-1.1.2
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
- sed -i -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
- -e '1irequire "set"' test/helper.rb || die
-
- # Fix assumption about parent directory name
- sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
-}
-
-each_ruby_test() {
- # Run tests directly to avoid dependencies in the Rakefile
- ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
-}
diff --git a/dev-ruby/sshkit/sshkit-1.11.0.ebuild b/dev-ruby/sshkit/sshkit-1.11.0.ebuild
deleted file mode 100644
index c8ee20de483f..000000000000
--- a/dev-ruby/sshkit/sshkit-1.11.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-# There are functional tests that require vagrant boxes to be set up.
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
-HOMEPAGE="https://github.com/capistrano/sshkit"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/net-ssh-2.8.0:*
- >=dev-ruby/net-scp-1.1.2
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
- sed -i -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
- -e '1irequire "set"' test/helper.rb || die
-
- # Fix assumption about parent directory name
- sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
-}
-
-each_ruby_test() {
- # Run tests directly to avoid dependencies in the Rakefile
- ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
-}
diff --git a/dev-ruby/sshkit/sshkit-1.11.1.ebuild b/dev-ruby/sshkit/sshkit-1.11.1.ebuild
deleted file mode 100644
index c8ee20de483f..000000000000
--- a/dev-ruby/sshkit/sshkit-1.11.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-# There are functional tests that require vagrant boxes to be set up.
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
-HOMEPAGE="https://github.com/capistrano/sshkit"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/net-ssh-2.8.0:*
- >=dev-ruby/net-scp-1.1.2
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
- sed -i -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
- -e '1irequire "set"' test/helper.rb || die
-
- # Fix assumption about parent directory name
- sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
-}
-
-each_ruby_test() {
- # Run tests directly to avoid dependencies in the Rakefile
- ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
-}