summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/mercurial/mercurial-4.9-r1.ebuild (renamed from dev-vcs/mercurial/mercurial-4.9.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-vcs/mercurial/mercurial-4.9.ebuild b/dev-vcs/mercurial/mercurial-4.9-r1.ebuild
index e0bacc4958f8..2c1934673ed4 100644
--- a/dev-vcs/mercurial/mercurial-4.9.ebuild
+++ b/dev-vcs/mercurial/mercurial-4.9-r1.ebuild
@@ -58,6 +58,7 @@ python_configure_all() {
python_compile_all() {
rm -r contrib/win32 || die
+ emake -C contrib/chg
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
@@ -85,7 +86,10 @@ python_install_all() {
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- local RM_CONTRIB=( hgk hg-ssh bash_completion zsh_completion wix plan9 *.el )
+ dobin contrib/chg/chg
+ doman contrib/chg/chg.1
+
+ local RM_CONTRIB=( chg hgk hg-ssh bash_completion zsh_completion wix plan9 *.el )
for f in ${RM_CONTRIB[@]}; do
rm -r contrib/${f} || die
done