summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/alpine/Manifest2
-rw-r--r--mail-client/alpine/alpine-2.22-r1.ebuild94
-rw-r--r--mail-client/alpine/alpine-2.22.ebuild90
-rw-r--r--mail-client/alpine/files/alpine-2.22-cc.patch24
-rw-r--r--mail-client/alpine/files/alpine-2.22-fno-common.patch19
5 files changed, 0 insertions, 229 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index f8bdceb6c75d..673ec9627e6c 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,4 +1,2 @@
-DIST alpine-2.22-chappa.patch.gz 173232 BLAKE2B ac2cfc22119c9e60fdc053212447fb5df8cc59781c049329560d21e19e67d700fe45a07649352747583b500a605499eeb61dfd83ba150c3bd58f4033486e2581 SHA512 9db36ebb4fb2efaee975ed33d44cf95780c56075cbc0ad39056268248db38109e1bb04e279b40cdd085b3dfec89d0f9c69aa4ddf5a64b5708437909661288e23
-DIST alpine-2.22.tar.xz 6336604 BLAKE2B 65cab2000b6c606c002efcca6e731d2c87329b4685dec81d202e95598b4302175137ea84f079af1f766a6ef99d0b2cb51132e12539bea7f4d24954bb48af7bea SHA512 7737dce02ac94170948df7fccb61380c6cb101190e37f5b3ba281d573f54df1db24569d177b460f49bfff381a922be2e4b0f3a0f1a213d88a64d361aedc3c4f1
DIST alpine-2.23-chappa.patch.gz 172604 BLAKE2B f814a269fe316dd42e73f98b09a67b26f8d0c5db9bc83ebcc6145f7f3373f14a5fa9f7991f60a4186c0f078428fa0a38bc81b0459998045ea433438f730f05a8 SHA512 5195db336651da161b3d94afeab8f46fd6bd3d1953db72b8f453355b46eafe8afe26eccb2466024f077fc3e40ff52e1a14a126ce3cc33fdcfcaeded67f9422d0
DIST alpine-2.23.tar.xz 6330784 BLAKE2B e7be73dc0ccf04cfbd8712e70f8b114063983b971c1d967765b41ab0bf86369815d954e85fc4d9622539b1e3a6324ffda635a2808b9439a123302e7f9c9f421d SHA512 abc3675b18d6bd20a547b8e2c3f1f4c668aee2f2d20f426f28b4b3d4cfd66762777007441da3b0fda74e625c71bc2ef05434089508c2af804e62cf216df5554b
diff --git a/mail-client/alpine/alpine-2.22-r1.ebuild b/mail-client/alpine/alpine-2.22-r1.ebuild
deleted file mode 100644
index 9a57c1139c81..000000000000
--- a/mail-client/alpine/alpine-2.22-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="An easy to use text-based based mail and news client"
-HOMEPAGE="http://alpine.x10host.com/alpine/ https://repo.or.cz/alpine.git/"
-CHAPPA_PATCH_NAME="${P}-chappa.patch"
-SRC_URI="http://alpine.x10host.com/alpine/release/src/${P}.tar.xz
- chappa? ( http://alpine.x10host.com/alpine/patches/${P}/all.patch.gz -> ${CHAPPA_PATCH_NAME}.gz ) "
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+chappa doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads"
-
-DEPEND=">=sys-libs/ncurses-5.1:0=
- kerberos? ( app-crypt/mit-krb5 )
- ldap? ( net-nds/openldap )
- spell? ( app-text/aspell )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
-"
-RDEPEND="${DEPEND}
- app-misc/mime-types
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-cc.patch"
- "${FILESDIR}/${P}-fno-common.patch"
-)
-
-src_prepare() {
- default
- use chappa && eapply "${WORKDIR}/${CHAPPA_PATCH_NAME}"
- eautoreconf
- tc-export CC RANLIB AR
- export CC_FOR_BUILD=$(tc-getBUILD_CC)
-}
-
-src_configure() {
- myconf=(
- --without-tcl
- --with-system-pinerc="${EPREFIX}"/etc/pine.conf
- --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
- $(use_with ldap)
- $(use_with ssl)
- $(use_with passfile passfile .pinepwd)
- $(use_with kerberos krb5)
- $(use_with threads pthread)
- $(use_with spell interactive-spellcheck /usr/bin/aspell)
- $(use_enable nls)
- $(use_with ipv6)
- $(use_with smime)
- )
-
- if use ssl; then
- myconf+=(
- --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
- --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
- --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
- )
- fi
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake -j1 AR=$(tc-getAR)
-}
-
-src_install() {
- if use onlyalpine ; then
- dobin alpine/alpine
- doman doc/man1/alpine.1
- else
- emake -j1 DESTDIR="${D}" install
- doman doc/man1/*.1
- fi
-
- dodoc NOTICE README*
-
- if use doc ; then
- dodoc doc/brochure.txt
-
- dodoc -r doc/tech-notes/
- newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
- newdoc "${S}/doc/mime.types" mime.types.sample
- docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
- fi
-}
diff --git a/mail-client/alpine/alpine-2.22.ebuild b/mail-client/alpine/alpine-2.22.ebuild
deleted file mode 100644
index 66f123bdd622..000000000000
--- a/mail-client/alpine/alpine-2.22.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="An easy to use text-based based mail and news client"
-HOMEPAGE="http://alpine.x10host.com/alpine/ https://repo.or.cz/alpine.git/"
-SRC_URI="http://alpine.x10host.com/alpine/release/src/${P}.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ppc ~sparc x86"
-IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads"
-
-DEPEND=">=sys-libs/ncurses-5.1:0=
- kerberos? ( app-crypt/mit-krb5 )
- ldap? ( net-nds/openldap )
- spell? ( app-text/aspell )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
-"
-RDEPEND="${DEPEND}
- app-misc/mime-types
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-cc.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
- tc-export CC RANLIB AR
- export CC_FOR_BUILD=$(tc-getBUILD_CC)
-}
-
-src_configure() {
- myconf=(
- --without-tcl
- --with-system-pinerc="${EPREFIX}"/etc/pine.conf
- --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
- $(use_with ldap)
- $(use_with ssl)
- $(use_with passfile passfile .pinepwd)
- $(use_with kerberos krb5)
- $(use_with threads pthread)
- $(use_with spell interactive-spellcheck /usr/bin/aspell)
- $(use_enable nls)
- $(use_with ipv6)
- $(use_with smime)
- )
-
- if use ssl; then
- myconf+=(
- --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
- --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
- --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
- )
- fi
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake -j1 AR=$(tc-getAR)
-}
-
-src_install() {
- if use onlyalpine ; then
- dobin alpine/alpine
- doman doc/man1/alpine.1
- else
- emake -j1 DESTDIR="${D}" install
- doman doc/man1/*.1
- fi
-
- dodoc NOTICE README*
-
- if use doc ; then
- dodoc doc/brochure.txt
-
- dodoc -r doc/tech-notes/
- newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
- newdoc "${S}/doc/mime.types" mime.types.sample
- docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
- fi
-}
diff --git a/mail-client/alpine/files/alpine-2.22-cc.patch b/mail-client/alpine/files/alpine-2.22-cc.patch
deleted file mode 100644
index 87132bdd6b51..000000000000
--- a/mail-client/alpine/files/alpine-2.22-cc.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./imap/tools/Makefile 2020-04-19 23:45:13.080083548 +0200
-+++ ./imap/tools/Makefile 2020-04-19 23:45:24.525083844 +0200
-@@ -21,7 +21,6 @@
- # Internet: MRC@CAC.Washington.EDU
-
-
--CC=cc
- RM=rm -f
-
-
---- ./imap/src/osdep/unix/Makefile 2020-04-19 23:54:55.454098598 +0200
-+++ ./imap/src/osdep/unix/Makefile 2020-04-19 23:54:55.454098598 +0200
-@@ -132,10 +132,8 @@
-
- # Commands possibly overridden by the individual port
-
--ARRC=ar rc
--CC=cc
-+ARRC=$(AR) rc
- LN=ln -s
--RANLIB=ranlib
-
-
- # Standard distribution build parameters
diff --git a/mail-client/alpine/files/alpine-2.22-fno-common.patch b/mail-client/alpine/files/alpine-2.22-fno-common.patch
deleted file mode 100644
index 0ef289eb8cdd..000000000000
--- a/mail-client/alpine/files/alpine-2.22-fno-common.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/pith/smkeys.c
-+++ b/pith/smkeys.c
-@@ -34,6 +34,7 @@ static char rcsid[] = "$Id: smkeys.c 1266 2009-07-14 18:39:12Z hubert@u.washingt
- #include "../pith/util.h"
- #include "../pith/mailindx.h"
- #include "../pith/readfile.h"
-+#include "../pith/options.h"
- #include "smkeys.h"
-
- #ifdef APPLEKEYCHAIN
-@@ -50,8 +51,6 @@ static int mem_add_extra_cacerts(char *contents, X509_LOOKUP *lookup);
- int compare_certs_by_name(const void *data1, const void *data2);
- int password_policy_check(char *);
-
--int (*pith_smime_enter_password)(char *, char *, size_t);
--
- /* test if password passes a predetermined policy.
- * return value: 0 - does not pass; 1 - it passes
- */