summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/pytorch/pytorch-1.12.0-r2.ebuild (renamed from sci-libs/pytorch/pytorch-1.12.0-r1.ebuild)13
1 files changed, 9 insertions, 4 deletions
diff --git a/sci-libs/pytorch/pytorch-1.12.0-r1.ebuild b/sci-libs/pytorch/pytorch-1.12.0-r2.ebuild
index 02fa58c7ba75..83a4944773f1 100644
--- a/sci-libs/pytorch/pytorch-1.12.0-r1.ebuild
+++ b/sci-libs/pytorch/pytorch-1.12.0-r2.ebuild
@@ -1,10 +1,11 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
DESCRIPTION="Tensors and Dynamic neural networks in Python"
@@ -20,11 +21,15 @@ RESTRICT="test"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="
${PYTHON_DEPS}
- ~sci-libs/caffe2-${PV}[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ~sci-libs/caffe2-${PV}[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ')
"
DEPEND="${RDEPEND}
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ')
"
src_prepare() {