summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-electronics/gspeakers/files/gspeakers-0.11-cxxflags.patch24
-rw-r--r--sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild26
2 files changed, 39 insertions, 11 deletions
diff --git a/sci-electronics/gspeakers/files/gspeakers-0.11-cxxflags.patch b/sci-electronics/gspeakers/files/gspeakers-0.11-cxxflags.patch
new file mode 100644
index 000000000000..a890921ab45f
--- /dev/null
+++ b/sci-electronics/gspeakers/files/gspeakers-0.11-cxxflags.patch
@@ -0,0 +1,24 @@
+From 849257811990d18789e6ce995423fcb5327f986e Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 14 Aug 2021 22:03:56 +0200
+Subject: [PATCH] Fix CXXFLAGS
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index cece557..7cb0f11 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -40,5 +40,5 @@ cellrendererpopup.h cellrendererpopup.cc \
+ crossoverimageview.h crossoverimageview.cc \
+ gspeakersfilechooser.h gspeakersfilechooser.cc
+
+-CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -Wall -O0
++CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -Wall
+ LDADD = $(DEPS_LIBS)
+--
+2.32.0
+
diff --git a/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild b/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
index 38be7a2bcdba..28ce47c011f6 100644
--- a/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
+++ b/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-GCONF_DEBUG="no"
+EAPI=7
-inherit autotools epatch flag-o-matic gnome2
+inherit autotools flag-o-matic gnome2
DESCRIPTION="GTK based loudspeaker enclosure and crossovernetwork designer"
HOMEPAGE="http://gspeakers.sourceforge.net/"
@@ -22,20 +21,25 @@ RDEPEND="
|| (
sci-electronics/gnucap
sci-electronics/ngspice
- sci-electronics/spice )
+ sci-electronics/spice
+ )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-cxxflags.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-glib-single-include.patch
+ "${FILESDIR}"/${P}-fix-sigc-includes.patch
+ "${FILESDIR}"/${P}-c++11.patch
+)
+
src_prepare() {
- sed -i -e "s/-O0//" src/Makefile.am
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-glib-single-include.patch
- epatch "${FILESDIR}"/${P}-fix-sigc-includes.patch
- epatch "${FILESDIR}"/${P}-c++11.patch
append-cxxflags '-std=c++11'
mv configure.in configure.ac || die
- eautoreconf
gnome2_src_prepare
+ eautoreconf
}