summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/pogo-manager-bin/Manifest1
-rw-r--r--games-util/pogo-manager-bin/files/pogo-manager17
-rw-r--r--games-util/pogo-manager-bin/metadata.xml11
-rw-r--r--games-util/pogo-manager-bin/pogo-manager-bin-0.1.4.ebuild35
4 files changed, 64 insertions, 0 deletions
diff --git a/games-util/pogo-manager-bin/Manifest b/games-util/pogo-manager-bin/Manifest
new file mode 100644
index 000000000000..cd6478f4e278
--- /dev/null
+++ b/games-util/pogo-manager-bin/Manifest
@@ -0,0 +1 @@
+DIST pogo-manager-bin-0.1.4.zip 7453967 SHA256 1ae061bade7bf3e9e66df028027f408895a6a07a52b80efcb7cb709984163633 SHA512 0fe21b4146d125d281f1aacd405dbc0370d6c5c043e82d4c964ca7df14ac0130459bf4d943268b6efd58a99ef05ca0d22dbf392ecb3853ab32e87fdb074209fa WHIRLPOOL 8c6cb33b788a98fd27a1d66a6292d1f87d0e2bd8678454a7e87d28b465d93e472c07548a045ef75ce9b067adcc2cbd956c5a60ffadfd6b68c7fe0e198775da80
diff --git a/games-util/pogo-manager-bin/files/pogo-manager b/games-util/pogo-manager-bin/files/pogo-manager
new file mode 100644
index 000000000000..9866fec91a84
--- /dev/null
+++ b/games-util/pogo-manager-bin/files/pogo-manager
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+# Config files are written to current directory, so make a config dir and pushd there
+
+if [[ ! -z "${XDG_CONFIG_DIR}" ]] ; then
+ config_dir="${XDG_CONFIG_DIR}/pogo-manager"
+elif [[ ! -z "${HOME}" ]] ; then
+ config_dir="${HOME}/.config/pogo-manager"
+else
+ config_dir="$(mktemp -d)"
+fi
+
+echo "Using ${config_dir} for configuration files"
+mkdir -p "${config_dir}"
+pushd "${config_dir}" > /dev/null
+java -Dfile.encoding=UTF-8 -jar /opt/pogo-manager/pogo-manager.jar
+
diff --git a/games-util/pogo-manager-bin/metadata.xml b/games-util/pogo-manager-bin/metadata.xml
new file mode 100644
index 000000000000..69f19ae21d9d
--- /dev/null
+++ b/games-util/pogo-manager-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wizardedit@gentoo.org</email>
+ <name>Austin English</name>
+ </maintainer>
+ <longdescription>
+ Utility to manage Pokemon Go accounts. Not sanctioned by Niantic, use at your own risk.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-util/pogo-manager-bin/pogo-manager-bin-0.1.4.ebuild b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.4.ebuild
new file mode 100644
index 000000000000..821b869f67e7
--- /dev/null
+++ b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/-bin}"
+
+DESCRIPTION="Pokemon Go manager"
+HOMEPAGE="https://github.com/Wolfsblvt/BlossomsPokemonGoManager"
+SRC_URI="https://github.com/Wolfsblvt/BlossomsPokemonGoManager/releases/download/v${PV}/BPGM_v${PV}.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-java/oracle-jdk-bin:1.8[javafx] dev-java/oracle-jre-bin:1.8[javafx] )"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/BPGM_v${PV}"
+
+src_install()
+{
+ insinto /opt/${MY_PN}
+ newins BlossomsPogoManager.jar ${MY_PN}.jar
+
+ dobin "${FILESDIR}/pogo-manager"
+}
+
+pkg_postinst()
+{
+ ewarn "Use of this tool is not sanctioned by Niantic and could get you banned."
+ ewarn "You have been warned!"
+}