summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/grub/grub-0.97-r17.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-boot/grub/grub-0.97-r17.ebuild b/sys-boot/grub/grub-0.97-r17.ebuild
index 038a541f8795..b34191f7346d 100644
--- a/sys-boot/grub/grub-0.97-r17.ebuild
+++ b/sys-boot/grub/grub-0.97-r17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
@@ -67,6 +67,13 @@ src_prepare() {
"${S}"/grub/asmstub.c \
|| die
+ # gcc-6 and above doesnt have a '-nopie' option patched in, use upstream's -no-pie
+ if (( $(gcc-major-version) > 5 )); then
+ sed -i 's/-nopie/-no-pie/' \
+ "${WORKDIR}"/patch/860_all_grub-0.97-pie.patch \
+ || die
+ fi
+
EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
# bug 564890, 566638
epatch "${FILESDIR}"/grub-0.97-Add-esp-to-list-of-clobbered-registers.patch