summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/crash/crash-8.0.3-r1.ebuild11
-rw-r--r--dev-util/crash/crash-8.0.4.ebuild11
-rw-r--r--dev-util/crash/crash-9999.ebuild11
3 files changed, 27 insertions, 6 deletions
diff --git a/dev-util/crash/crash-8.0.3-r1.ebuild b/dev-util/crash/crash-8.0.3-r1.ebuild
index e2c69feeeb4e..a7ffd58cb9a5 100644
--- a/dev-util/crash/crash-8.0.3-r1.ebuild
+++ b/dev-util/crash/crash-8.0.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
GDB_VERSION=10.2
UPSTREAM_VER=
@@ -59,6 +59,13 @@ src_prepare() {
ln -s "${DISTDIR}"/gdb-10.2.tar.gz . || die
}
+src_configure() {
+ # bug #858344
+ filter-lto
+
+ default
+}
+
src_compile() {
emake \
CC="$(tc-getCC)" \
diff --git a/dev-util/crash/crash-8.0.4.ebuild b/dev-util/crash/crash-8.0.4.ebuild
index 3e9f60e22613..2e850186dedf 100644
--- a/dev-util/crash/crash-8.0.4.ebuild
+++ b/dev-util/crash/crash-8.0.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
GDB_VERSION=10.2
UPSTREAM_VER=
@@ -54,6 +54,13 @@ src_prepare() {
ln -s "${DISTDIR}"/gdb-10.2.tar.gz . || die
}
+src_configure() {
+ # bug #858344
+ filter-lto
+
+ default
+}
+
src_compile() {
emake \
CC="$(tc-getCC)" \
diff --git a/dev-util/crash/crash-9999.ebuild b/dev-util/crash/crash-9999.ebuild
index e5ef7a7ea356..34c8d94dfb93 100644
--- a/dev-util/crash/crash-9999.ebuild
+++ b/dev-util/crash/crash-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
GDB_VERSION=10.2
if [[ ${PV} == "9999" ]] ; then
@@ -33,6 +33,13 @@ src_prepare() {
ln -s "${DISTDIR}"/gdb-10.2.tar.gz . || die
}
+src_configure() {
+ # bug #858344
+ filter-lto
+
+ default
+}
+
src_compile() {
emake \
CC="$(tc-getCC)" \