summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/eflite')
-rw-r--r--app-accessibility/eflite/Manifest1
-rw-r--r--app-accessibility/eflite/eflite-0.4.1-r3.ebuild46
-rw-r--r--app-accessibility/eflite/files/eflite-0.4.1-flite14.patch24
-rw-r--r--app-accessibility/eflite/files/eflite.rc28
-rw-r--r--app-accessibility/eflite/files/es.conf11
-rw-r--r--app-accessibility/eflite/metadata.xml33
6 files changed, 0 insertions, 143 deletions
diff --git a/app-accessibility/eflite/Manifest b/app-accessibility/eflite/Manifest
deleted file mode 100644
index ef12510aac5d..000000000000
--- a/app-accessibility/eflite/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST eflite-0.4.1.tar.gz 63192 BLAKE2B 4bdd8bf689732ac56918cefc42d9443ce09d27db052f218c34d7e6b2734e12835482b5c3e3e99f9e2cfe9d1645f683e67aec1ecdbc00c8967637d65d59fd14e3 SHA512 0060980fd5bb65ad94f1609f6d87cb89b91e680228b603fa590e6ba70b51e894493dda4271dca4d8c97f38cdefbd456c3be0447e5f88a0be7ae39324baa2c796
diff --git a/app-accessibility/eflite/eflite-0.4.1-r3.ebuild b/app-accessibility/eflite/eflite-0.4.1-r3.ebuild
deleted file mode 100644
index 6b6c7c7a905a..000000000000
--- a/app-accessibility/eflite/eflite-0.4.1-r3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools epatch user
-
-DESCRIPTION="A speech server that allows screen readers to interact with festival lite"
-HOMEPAGE="http://eflite.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
-IUSE="+16k_voice"
-
-DEPEND=">=app-accessibility/flite-1.4"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -i 's:/etc/es.conf:/etc/eflite/es.conf:g' * || die
- epatch "${FILESDIR}"/${PN}-0.4.1-flite14.patch
- eautoreconf
-}
-
-src_configure() {
- local myconf
- if use 16k_voice; then
- myconf='--with-vox=cmu_us_kal16'
- fi
- econf ${myconf}
-}
-
-src_install() {
- einstall
- dodoc ChangeLog README INSTALL eflite_test.txt
-
- insinto /etc/eflite
- doins "${FILESDIR}"/es.conf
-
- newinitd "${FILESDIR}"/eflite.rc eflite
-}
-
-pkg_postinst() {
- enewgroup speech
-}
diff --git a/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
deleted file mode 100644
index cb3096d88a43..000000000000
--- a/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur eflite-0.4.1/Makefile.in eflite-0.4.1-new/Makefile.in
---- eflite-0.4.1/Makefile.in 2007-01-18 18:01:09.000000000 -0600
-+++ eflite-0.4.1-new/Makefile.in 2010-07-23 20:06:45.000000000 -0500
-@@ -34,7 +34,7 @@
- $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
-
- fs.o: fs.c
-- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
-+ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
-
- tone.o: tone.c
- $(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<
-diff -Naur eflite-0.4.1/fs.c eflite-0.4.1.new/fs.c
---- eflite-0.4.1/fs.c 2007-01-18 16:01:09.000000000 -0800
-+++ eflite-0.4.1.new/fs.c 2013-09-08 09:31:57.417262688 -0700
-@@ -523,7 +523,7 @@
- int playlen, skip;
- if (type == SPEECH)
- {
-- skip = (187 * wptr->sample_rate) / speed;
-+ skip = 0;
- playlen = wptr->num_samples - (skip * 2);
- if (playlen > 0 && playlen < 500) playlen += (skip * 2) / 3;
- }
diff --git a/app-accessibility/eflite/files/eflite.rc b/app-accessibility/eflite/files/eflite.rc
deleted file mode 100644
index 2a65b04d0a8a..000000000000
--- a/app-accessibility/eflite/files/eflite.rc
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- use alsasound
- use modules
- use hotplug
-}
-
-start() {
- ebegin "Starting eflite"
- start-stop-daemon --start --exec /usr/bin/eflite --background \
- --quiet --pidfile /var/run/eflite.pid --make-pidfile -- -D || eend 1
-
- SOCKET=`egrep '^sockname=' /etc/eflite/es.conf | sed 's/^sockname=//'`
- [ ! -S ${SOCKET} ] && SOCKET=/tmp/es.socket
-
- chown root:speech ${SOCKET}
- chmod 660 ${SOCKET}
- eend $?
-}
-
-stop() {
- ebegin "Stopping eflite"
- start-stop-daemon --stop --quiet --pidfile /var/run/eflite.pid
- eend $?
-}
diff --git a/app-accessibility/eflite/files/es.conf b/app-accessibility/eflite/files/es.conf
deleted file mode 100644
index 17443d3e42ba..000000000000
--- a/app-accessibility/eflite/files/es.conf
+++ /dev/null
@@ -1,11 +0,0 @@
-# What socket do we listen on
-sockname=/tmp/es.socket
-
-# What volume do we set?
-tone_volume=8192
-
-# Do we use the PC Speaker? (0/1)
-speaker_tones=0
-
-# Do we use the sound card (via flite)? (0/1)
-soundcard_tones=1
diff --git a/app-accessibility/eflite/metadata.xml b/app-accessibility/eflite/metadata.xml
deleted file mode 100644
index 9c8a9fdaf58f..000000000000
--- a/app-accessibility/eflite/metadata.xml
+++ /dev/null
@@ -1,33 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>williamh@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>accessibility@gentoo.org</email>
- <name>Gentoo Accessibility Project</name>
- </maintainer>
- <maintainer type="project">
- <email>sound@gentoo.org</email>
- <name>Gentoo Sound project</name>
- </maintainer>
- <use>
- <flag name="16k_voice">Use a higher-quality voice.</flag>
- </use>
- <longdescription lang="en">
- EFlite is a speech server for Emacspeak and other screen readers
- that allows them to interface with Festival Lite, a free
- text-to-speech engine developed at the CMU Speech Center as an
- off-shoot of Festival.
-</longdescription>
- <longdescription lang="ja">
- EFliteはEmacspeakと他のスクリーン読取り装置のスピーチサーバ。この
- サーバーで前のプログラムはFestival Lite(CMU Speech Centerで開発した
- Festivalのようにスピーチにテキストを変わるエンジン。)と
- インタフェスすることが出来る。
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">eflite</remote-id>
- </upstream>
-</pkgmetadata>