summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild')
-rw-r--r--app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild b/app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild
new file mode 100644
index 000000000000..3bed31781f04
--- /dev/null
+++ b/app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P=${P/_/}
+
+DESCRIPTION="CMU Speech Recognition-engine"
+HOMEPAGE="https://cmusphinx.github.io"
+SRC_URI="https://downloads.sourceforge.net/cmusphinx/${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DOCS=( AUTHORS ChangeLog README NEWS
+ doc/{README.{bin,lib},SCHMM_format,filler.dict,phoneset{,-old}} )
+HTML_DOCS=( doc/{phoneset_s2,sphinx2}.html )
+
+PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ rm -r "${ED}/usr/share/${PN}/doc" || die
+ find "${ED}" -name '*.la' -delete || die
+}