summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.22.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index b95c08e0d878..e33a6248263e 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.20.2.tar.xz 454124 SHA256 88a4de9d43139f13cca531b47b901bc1b56e0ab06ba899126644abd4ac16a143 SHA512 b92eb876ecc1fbd14c042a37d0d781c2b3697ad3e988d3fa2c8894f5ffc269b38a703fee702a1a03d8b37b7c2140a7862cd818c9c7f66bc85bfa776355172d79 WHIRLPOOL 07f99b4b4167875f26952747a8e9fb8ec2cf92898d57a0d4b41420e25d09b8ea7145cea994860959af8ffe78d2ba8fee6900932145ebba9d5047bf832d79617c
DIST at-spi2-core-2.22.0.tar.xz 449364 SHA256 415ea3af21318308798e098be8b3a17b2f0cf2fe16cecde5ad840cf4e0f2c80a SHA512 f43fde89a47754a6fab80ebecb6c303b50d4829b4b376f363c085841243b30910003bc359ec16fc20f4363253df06b8e0f818b91d96b03c99b29f9a1ab5af118 WHIRLPOOL f1c476c38fee5e157ea62ea37211e9419c708abd465dc74a040ba32a88490f23a614be8ae1a0cc1af005633bf77f2495e45b986d2c6ebeea5ed7c13895a59568
+DIST at-spi2-core-2.22.1.tar.xz 454048 SHA256 6f8f39f091bfe2c57870cb8bfbb02edac4fc85cda69665e6967937daf7201c42 SHA512 2376b57ce744351ed09a13cd02f0c02264c0998860710cfcdac59f0efb78061512986f5d7305a2f6c594d70213722f81795620e8cd2c6587c6d3f1335477171f WHIRLPOOL a3bd869b286e7fd974242c5846d219c9be3b5fb4322f7bd82f9c039cd032bbfc0917e2e54dc900283eb13a1bba14906eec3f2ef9d9b3caae1aef6bdce24fe3be
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.22.1.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.22.1.ebuild
new file mode 100644
index 000000000000..7a3aed291611
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.22.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="X +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+
+# x11-libs/libSM is needed until upstream #719808 is solved either
+# making the dep unneeded or fixing their configure
+# Only libX11 is optional right now
+RDEPEND="
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+PATCHES=(
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+)
+
+multilib_src_configure() {
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-xevie \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable X x11)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/libatspi/html doc/libatspi/html || die
+ fi
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }