summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/abrt')
-rw-r--r--app-admin/abrt/Manifest3
-rw-r--r--app-admin/abrt/abrt-2.14.0.ebuild129
-rw-r--r--app-admin/abrt/abrt-2.14.1.ebuild129
-rw-r--r--app-admin/abrt/abrt-2.14.2.ebuild129
-rw-r--r--app-admin/abrt/files/abrt-2.0.12-r1-conf27
-rw-r--r--app-admin/abrt/files/abrt-2.0.12-r1-init76
-rw-r--r--app-admin/abrt/metadata.xml11
7 files changed, 0 insertions, 504 deletions
diff --git a/app-admin/abrt/Manifest b/app-admin/abrt/Manifest
deleted file mode 100644
index 373d7214a7bf..000000000000
--- a/app-admin/abrt/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST abrt-2.14.0.tar.gz 6102393 BLAKE2B 6bba45604406c1f2f84d778475acc6b5db3747f292fcb74a881703491b2d92adda3cc88d6ed741087c1ed2f88a68cdc4858f3640b506a6be650ea4d1d1f2bfd3 SHA512 26cf04ef6f52da445e825d5f1074186c4c77d1b093174bb6f7b0a8fa6175e265fcaf56fa4a977851a2352f9fd004425bc397e35a91f6f8e78f37564cd492c571
-DIST abrt-2.14.1.tar.gz 6113024 BLAKE2B ddceda689fa51b04a0c201fe560c31ba5c8233c1f75c878b391b0b61cff241e6c2ce5b1829faa6e5f286c3c5efe96941c823234affe94b59fdd2aa3d7cd33cc3 SHA512 24126a54778b7e612c8b950321686bdee7ce15a16e79c8d967f8126c89f7da7060270fc0929cfabfc35100d069b0a626c3380833a3f62614cea6b00a44238ec3
-DIST abrt-2.14.2.tar.gz 6113632 BLAKE2B 904ec2ca4c3aa70b62573ca2730742689f4446c1e5f04bfb6dc4267a4a9a6d44ef8c2b6e82c1e0aba04876b400c3a965a879da65bbff7ec729846f1b5c28cdf9 SHA512 82ba10cb151b4585024e3dfc626f46a7d967797e0375158cd76355c4f6a66c59578cc7b41bc5d5aaa3e694b3653b8658650df458676225660cfe95ec318c6886
diff --git a/app-admin/abrt/abrt-2.14.0.ebuild b/app-admin/abrt/abrt-2.14.0.ebuild
deleted file mode 100644
index 2664d60151a3..000000000000
--- a/app-admin/abrt/abrt-2.14.0.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit autotools python-single-r1 systemd xdg-utils
-
-DESCRIPTION="Automatic bug detection and reporting tool"
-HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="selinux test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.56:2
- >=dev-libs/libreport-2.10.0[gtk,python]
- dev-libs/libxml2:2
- >=gnome-base/gsettings-desktop-schemas-3.15.1
- net-libs/libsoup:2.4
- sys-apps/dbus
- sys-apps/systemd:0=
- sys-auth/polkit
- sys-libs/libcap
- sys-fs/inotify-tools
- x11-libs/gtk+:3
-"
-RDEPEND="${DEPEND}
- acct-user/abrt
- acct-group/abrt
- app-arch/cpio
- app-arch/rpm[python,${PYTHON_SINGLE_USEDEP}]
- dev-libs/elfutils
- dev-libs/json-c:0=
- sys-apps/util-linux
- >=sys-devel/gdb-7
- $(python_gen_cond_dep '
- dev-libs/satyr[${PYTHON_MULTI_USEDEP}]
- dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
- dev-python/argh[${PYTHON_MULTI_USEDEP}]
- dev-python/humanize[${PYTHON_MULTI_USEDEP}]
- ')
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_MULTI_USEDEP}]')
- )
- app-text/asciidoc
- app-text/xmlto
- >=dev-util/intltool-0.35.0
- virtual/pkgconfig
- >=sys-devel/gettext-0.17
-"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- python_fix_shebang .
- default
-
- # Install under proper directory
- sed -i -e 's:dbusabrtdocdir = ${datadir}/doc/abrt-dbus-${VERSION}/html:dbusabrtdocdir = ${datadir}/doc/${PF}/html:' doc/problems-service/Makefile.am || die
-
- # Ensure this works for systems with and without /usr merge
- sed -i -e "s:/usr/bin/bash:$(which bash):" init-scripts/abrtd.service || die
-
- # Fix hardcoded "pytest-3"
- sed -i -e "s:pytest-3:pytest:" \
- configure.ac src/python-problem/tests/Makefile.am src/cli/test || die
-
- # pyhook test is sensitive to the format of python's error messages, and
- # fails with certain python versions
- sed -e '/pyhook.at/ d' \
- -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
- ./gen-version || die # Needed to be run before autoreconf
- eautoreconf
-}
-
-src_configure() {
- myeconfargs=(
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --localstatedir="${EPREFIX}/var"
- --without-bodhi
- # package breaks due to not finding libreport-web with bodhi plugin enabled
- --without-rpm
- $(usex selinux "" "--without-selinux")
- --with-python3
- --without-pythondoc
- # package breaks due to no sphinx-build-3
- $(use_with test pythontests)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- python_optimize
-
- keepdir /var/run/abrt
- # /var/spool/abrt is created by dev-libs/libreport
-
- diropts -m 700 -o abrt -g abrt
- keepdir /var/spool/abrt-upload
-
- diropts -m 775 -o abrt -g abrt
- keepdir /var/cache/abrt-di
-
- find "${D}" -name '*.la' -delete || die
-
- newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
- newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/app-admin/abrt/abrt-2.14.1.ebuild b/app-admin/abrt/abrt-2.14.1.ebuild
deleted file mode 100644
index 0c87155270c0..000000000000
--- a/app-admin/abrt/abrt-2.14.1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit autotools python-single-r1 systemd xdg-utils
-
-DESCRIPTION="Automatic bug detection and reporting tool"
-HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="selinux test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.56:2
- >=dev-libs/libreport-2.10.0[gtk,python]
- dev-libs/libxml2:2
- >=gnome-base/gsettings-desktop-schemas-3.15.1
- net-libs/libsoup:2.4
- sys-apps/dbus
- sys-apps/systemd:0=
- sys-auth/polkit
- sys-libs/libcap
- sys-fs/inotify-tools
- x11-libs/gtk+:3
-"
-RDEPEND="${DEPEND}
- acct-user/abrt
- acct-group/abrt
- app-arch/cpio
- app-arch/rpm[python,${PYTHON_SINGLE_USEDEP}]
- dev-libs/elfutils
- dev-libs/json-c:0=
- sys-apps/util-linux
- >=sys-devel/gdb-7
- $(python_gen_cond_dep '
- dev-libs/satyr[${PYTHON_MULTI_USEDEP}]
- dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
- dev-python/argh[${PYTHON_MULTI_USEDEP}]
- dev-python/humanize[${PYTHON_MULTI_USEDEP}]
- ')
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_MULTI_USEDEP}]')
- )
- app-text/asciidoc
- app-text/xmlto
- >=dev-util/intltool-0.35.0
- virtual/pkgconfig
- >=sys-devel/gettext-0.17
-"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- python_fix_shebang .
- default
-
- # Install under proper directory
- sed -i -e 's:dbusabrtdocdir = ${datadir}/doc/abrt-dbus-${VERSION}/html:dbusabrtdocdir = ${datadir}/doc/${PF}/html:' doc/problems-service/Makefile.am || die
-
- # Ensure this works for systems with and without /usr merge
- sed -i -e "s:/usr/bin/bash:$(which bash):" init-scripts/abrtd.service || die
-
- # Fix hardcoded "pytest-3"
- sed -i -e "s:pytest-3:pytest:" \
- configure.ac src/python-problem/tests/Makefile.am src/cli/test || die
-
- # pyhook test is sensitive to the format of python's error messages, and
- # fails with certain python versions
- sed -e '/pyhook.at/ d' \
- -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
- ./gen-version || die # Needed to be run before autoreconf
- eautoreconf
-}
-
-src_configure() {
- myeconfargs=(
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --localstatedir="${EPREFIX}/var"
- --without-bodhi
- # package breaks due to not finding libreport-web with bodhi plugin enabled
- --without-rpm
- $(usex selinux "" "--without-selinux")
- --with-python3
- --without-pythondoc
- # package breaks due to no sphinx-build-3
- $(use_with test pythontests)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- python_optimize
-
- keepdir /var/run/abrt
- # /var/spool/abrt is created by dev-libs/libreport
-
- diropts -m 700 -o abrt -g abrt
- keepdir /var/spool/abrt-upload
-
- diropts -m 775 -o abrt -g abrt
- keepdir /var/cache/abrt-di
-
- find "${D}" -name '*.la' -delete || die
-
- newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
- newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/app-admin/abrt/abrt-2.14.2.ebuild b/app-admin/abrt/abrt-2.14.2.ebuild
deleted file mode 100644
index 1071f21d2393..000000000000
--- a/app-admin/abrt/abrt-2.14.2.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit autotools python-single-r1 systemd xdg-utils
-
-DESCRIPTION="Automatic bug detection and reporting tool"
-HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="selinux test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.56:2
- >=dev-libs/libreport-2.13.0[gtk,python]
- dev-libs/libxml2:2
- >=gnome-base/gsettings-desktop-schemas-3.15.1
- net-libs/libsoup:2.4
- sys-apps/dbus
- sys-apps/systemd:0=
- sys-auth/polkit
- sys-libs/libcap
- sys-fs/inotify-tools
- x11-libs/gtk+:3
-"
-RDEPEND="${DEPEND}
- acct-user/abrt
- acct-group/abrt
- app-arch/cpio
- app-arch/rpm[python,${PYTHON_SINGLE_USEDEP}]
- dev-libs/elfutils
- dev-libs/json-c:0=
- sys-apps/util-linux
- >=sys-devel/gdb-7
- $(python_gen_cond_dep '
- dev-libs/satyr[${PYTHON_MULTI_USEDEP}]
- dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
- dev-python/argh[${PYTHON_MULTI_USEDEP}]
- dev-python/humanize[${PYTHON_MULTI_USEDEP}]
- ')
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_MULTI_USEDEP}]')
- )
- app-text/asciidoc
- app-text/xmlto
- >=dev-util/intltool-0.35.0
- virtual/pkgconfig
- >=sys-devel/gettext-0.17
-"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- python_fix_shebang .
- default
-
- # Install under proper directory
- sed -i -e 's:dbusabrtdocdir = ${datadir}/doc/abrt-dbus-${VERSION}/html:dbusabrtdocdir = ${datadir}/doc/${PF}/html:' doc/problems-service/Makefile.am || die
-
- # Ensure this works for systems with and without /usr merge
- sed -i -e "s:/usr/bin/bash:$(which bash):" init-scripts/abrtd.service || die
-
- # Fix hardcoded "pytest-3"
- sed -i -e "s:pytest-3:pytest:" \
- configure.ac src/python-problem/tests/Makefile.am src/cli/test || die
-
- # pyhook test is sensitive to the format of python's error messages, and
- # fails with certain python versions
- sed -e '/pyhook.at/ d' \
- -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
- ./gen-version || die # Needed to be run before autoreconf
- eautoreconf
-}
-
-src_configure() {
- myeconfargs=(
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --localstatedir="${EPREFIX}/var"
- --without-bodhi
- # package breaks due to not finding libreport-web with bodhi plugin enabled
- --without-rpm
- $(usex selinux "" "--without-selinux")
- --with-python3
- --without-pythondoc
- # package breaks due to no sphinx-build-3
- $(use_with test pythontests)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- python_optimize
-
- keepdir /var/run/abrt
- # /var/spool/abrt is created by dev-libs/libreport
-
- diropts -m 700 -o abrt -g abrt
- keepdir /var/spool/abrt-upload
-
- diropts -m 775 -o abrt -g abrt
- keepdir /var/cache/abrt-di
-
- find "${D}" -name '*.la' -delete || die
-
- newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
- newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/app-admin/abrt/files/abrt-2.0.12-r1-conf b/app-admin/abrt/files/abrt-2.0.12-r1-conf
deleted file mode 100644
index 073eb0daf82e..000000000000
--- a/app-admin/abrt/files/abrt-2.0.12-r1-conf
+++ /dev/null
@@ -1,27 +0,0 @@
-# abrtd command-line options
-# Default: ""
-ABRTD_OPTS=""
-
-# Run abrt-harvest-vmcore to make new kdump dumps available for abrtd
-START_VMCORE="yes"
-
-# Install abrt-ccpp hook to watch for segfaults
-START_CCPP="yes"
-
-# Call abrt-dump-oops to log kernel oops
-START_OOPS="yes"
-# log file to watch for kernel oops
-# Default: "/var/log/messages"
-OOPS_WATCH_LOG="/var/log/messages"
-# abrt-dump-oops command-line options
-# Default: "-xD"
-OOPS_DUMP_OPTS="-xD"
-
-# Call abrt-dump-xorg to log X crashes
-START_XORG="yes"
-# log file to watch for X crashes
-# Default: "/var/log/Xorg.0.log"
-XORG_WATCH_LOG="/var/log/Xorg.0.log"
-# abrt-dump-xorg command-line options
-# Default: "-xD"
-XORG_DUMP_OPTS="-xD"
diff --git a/app-admin/abrt/files/abrt-2.0.12-r1-init b/app-admin/abrt/files/abrt-2.0.12-r1-init
deleted file mode 100644
index 3fb32b7c3e43..000000000000
--- a/app-admin/abrt/files/abrt-2.0.12-r1-init
+++ /dev/null
@@ -1,76 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-description="Automated crash detection service"
-
-depend() {
- need dbus logger
-}
-
-start() {
- ebegin "Starting abrtd"
- start-stop-daemon --start --quiet --pidfile /var/run/abrt/abrtd.pid \
- --exec /usr/sbin/abrtd -- ${ABRTD_OPTS}
- eend $?
-
- if [ "${START_VMCORE}" = "yes" ]; then
- ebegin "Running abrt-harvest-vmcore"
- /usr/sbin/abrt-harvest-vmcore
- eend $?
- fi
-
- if [ "${START_CCPP}" = "yes" ]; then
- ebegin "Installing abrt-ccpp hook"
- /usr/sbin/abrt-install-ccpp-hook install
- eend $?
- fi
-
- if [ "${START_OOPS}" = "yes" ]; then
- ebegin "Starting abrt-dump-oops"
- start-stop-daemon --start --quiet \
- --pidfile /var/run/abrt/abrt-dump-oops.pid \
- --make-pidfile --background \
- --exec /usr/bin/abrt-watch-log -- \
- -F "`/usr/bin/abrt-dump-oops -m`" ${OOPS_WATCH_LOG} -- \
- /usr/bin/abrt-dump-oops ${OOPS_DUMP_OPTS}
- eend $?
- fi
-
- if [ "${START_XORG}" = "yes" ]; then
- ebegin "Starting abrt-dump-xorg"
- start-stop-daemon --start --quiet \
- --pidfile /var/run/abrt/abrt-dump-xorg.pid \
- --make-pidfile --background \
- --exec /usr/bin/abrt-watch-log -- \
- -F "`/usr/bin/abrt-dump-xorg -m`" ${XORG_WATCH_LOG} -- \
- /usr/bin/abrt-dump-xorg ${XORG_DUMP_OPTS}
- eend $?
- fi
-}
-
-stop() {
- if [ "${START_XORG}" = "yes" ]; then
- ebegin "Stopping abrt-dump-xorg"
- start-stop-daemon --stop --quiet \
- --pidfile /var/run/abrt/abrt-dump-xorg.pid
- eend $?
- fi
-
- if [ "${START_OOPS}" = "yes" ]; then
- ebegin "Stopping abrt-dump-oops"
- start-stop-daemon --stop --quiet \
- --pidfile /var/run/abrt/abrt-dump-oops.pid
- eend $?
- fi
-
- if [ "${START_CCPP}" = "yes" ]; then
- ebegin "Uninstalling abrt-ccpp hook"
- /usr/sbin/abrt-install-ccpp-hook uninstall
- eend $?
- fi
-
- ebegin "Stopping abrtd"
- start-stop-daemon --stop --quiet --pidfile /var/run/abrt/abrtd.pid
- eend $?
-}
diff --git a/app-admin/abrt/metadata.xml b/app-admin/abrt/metadata.xml
deleted file mode 100644
index a14673b81f96..000000000000
--- a/app-admin/abrt/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <upstream>
- <remote-id type="github">abrt/abrt</remote-id>
- </upstream>
-</pkgmetadata>