summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible-base')
-rw-r--r--app-admin/ansible-base/Manifest1
-rw-r--r--app-admin/ansible-base/ansible-base-2.10.2.ebuild77
-rw-r--r--app-admin/ansible-base/metadata.xml35
3 files changed, 0 insertions, 113 deletions
diff --git a/app-admin/ansible-base/Manifest b/app-admin/ansible-base/Manifest
deleted file mode 100644
index 9fddfe32080b..000000000000
--- a/app-admin/ansible-base/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ansible-base-2.10.2.tar.gz 6023200 BLAKE2B 80abfa3fab56d3f997cbe90b557ffd5004b216709d6ba2c6d50ea0fb7a2e5a2ad49ce83bfc7a17054582e786f53ce29814d8b5a3fc2408a1e729b1647619080c SHA512 2ee60303841e88d3451ddbcc4c18473d3a37253873406b0783816b1bbf9d8404599ebed12bac7c7f32693314048668b84f3a1c593621c7b8c37a7b48687c769b
diff --git a/app-admin/ansible-base/ansible-base-2.10.2.ebuild b/app-admin/ansible-base/ansible-base-2.10.2.ebuild
deleted file mode 100644
index 6843d55c4702..000000000000
--- a/app-admin/ansible-base/ansible-base-2.10.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- !<app-admin/ansible-2.10
-"
-# ansible-2.10 or above is needed for the collections
-DEPEND="
- !<app-admin/ansible-2.10
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- # disable version checks on upgrade
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-
- dodoc -r examples
-}
diff --git a/app-admin/ansible-base/metadata.xml b/app-admin/ansible-base/metadata.xml
deleted file mode 100644
index 8e285e3eb63a..000000000000
--- a/app-admin/ansible-base/metadata.xml
+++ /dev/null
@@ -1,35 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>chainsaw@gentoo.org</email>
- <name>Tony Vroon</name>
- </maintainer>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <maintainer type="person">
- <email>calchan@gentoo.org</email>
- <name>Denis Dupeyron</name>
- </maintainer>
- <maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">ansible-base</remote-id>
- <remote-id type="github">ansible/ansible</remote-id>
- <bugs-to>https://github.com/ansible/ansible/issues</bugs-to>
- </upstream>
- <longdescription lang="en">
-Radically simple deployment, model-driven configuration management, and
-command execution framework.
-
-This is a minimal installation of Ansible which contains the core programs,
-some documentation, and a tiny subset of modules and plugins to allow for a
-functioning controller. All other modules, including most of those
-bundled with in Ansible 2.9 and older, must be installed separately,
-e.g. from collections.
-</longdescription>
-</pkgmetadata>