summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.17.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 67d96b5d728c..eea84ca1ae25 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1 +1,2 @@
DIST ansible-lint-6.17.1.tar.gz 479782 BLAKE2B ae9a234f9552fd64520fa244cf0386370f103586a4764c412867f62e67e7a325b47be55e431451f42fbfaf0a9bb2d53ab8fbc9b87ea55ae2cc1c20439a6f8896 SHA512 38cd185fd84dc91b2bf84acc6d975dc5d5e90fd2f08d22651e470329ca1609dc73826f28f8cee391c101146dd91aff32f6e16f02b98c48f0d15b3422ba08db75
+DIST ansible-lint-6.17.2.tar.gz 480923 BLAKE2B 709c0855529d82058508ff1cba37dcfe04dafdbf5b56fa48085a692ddab3a29544867ebcf02a4bc4bd612786d3a7c145f974a2080d7c4be0a075cc8a0e55f30a SHA512 109df229281b3a20b88af125cf1833dc7cb9eb1000470b085e2ca401d87cbac6a64daddb76216fe0f70fc2088f2a5ea6042ab281c7b3d405e59ec2686e1b7e3b
diff --git a/app-admin/ansible-lint/ansible-lint-6.17.2.ebuild b/app-admin/ansible-lint/ansible-lint-6.17.2.ebuild
new file mode 100644
index 000000000000..c69f26213309
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-6.17.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.0.5[${PYTHON_USEDEP}]
+ >=dev-python/black-22.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.17.31[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.3.2[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}