summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/apachetop')
-rw-r--r--app-admin/apachetop/Manifest1
-rw-r--r--app-admin/apachetop/apachetop-0.19.7.ebuild6
-rw-r--r--app-admin/apachetop/apachetop-0.23.2.ebuild29
-rw-r--r--app-admin/apachetop/files/apachetop-0.19.7-c++17.patch90
-rw-r--r--app-admin/apachetop/metadata.xml7
5 files changed, 130 insertions, 3 deletions
diff --git a/app-admin/apachetop/Manifest b/app-admin/apachetop/Manifest
index 3b37485c6fe9..60760ae14846 100644
--- a/app-admin/apachetop/Manifest
+++ b/app-admin/apachetop/Manifest
@@ -1 +1,2 @@
DIST apachetop-0.19.7.tar.gz 132665 BLAKE2B 248247c361d1585de68a0a9adae22f98db72991babfb4a75f01fa67ef28443a3c04cf1da9c1ea34ed923599955b58959528cc9e0a881fbb7b463b1d64c0cb7bd SHA512 40d546facee23a9914483c06323940e219602518751d80f729d835c4dbf991c7d1dd9bcebcaa4ca6a2d64799d48c8a00d421bc324afc2959691c962113386969
+DIST apachetop-0.23.2.tar.gz 169381 BLAKE2B fd524e8b313c8536bf016ab481f93d73ff32f256634b9fcc28c035207fda6821298087c240227508c1ab6fb7f80a0879945cc931125204bf81c3897b3d33408e SHA512 c278b6fc286eacb69746547e562c40eec50e7ff55df22a32e9387af057c25801e331c6c4b286726aa1bcee6ebcd3578747aca25be3dfec1745b876e95696d7fc
diff --git a/app-admin/apachetop/apachetop-0.19.7.ebuild b/app-admin/apachetop/apachetop-0.19.7.ebuild
index 816b03798ef0..aaf86e4822f9 100644
--- a/app-admin/apachetop/apachetop-0.19.7.ebuild
+++ b/app-admin/apachetop/apachetop-0.19.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.19.7-c++17.patch
+)
+
src_configure() {
econf \
--with-logfile="${EPREFIX}"/var/log/apache2/access_log \
diff --git a/app-admin/apachetop/apachetop-0.23.2.ebuild b/app-admin/apachetop/apachetop-0.23.2.ebuild
new file mode 100644
index 000000000000..e76b94f46fed
--- /dev/null
+++ b/app-admin/apachetop/apachetop-0.23.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A realtime Apache log analyzer"
+HOMEPAGE="https://github.com/tessus/apachetop"
+SRC_URI="https://github.com/tessus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ppc sparc x86"
+IUSE="fam pcre"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ fam? ( virtual/fam )
+ pcre? ( dev-libs/libpcre2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-logfile="${EPREFIX}"/var/log/apache2/access_log \
+ --without-adns \
+ $(use_with fam) \
+ $(use_with pcre pcre2)
+}
diff --git a/app-admin/apachetop/files/apachetop-0.19.7-c++17.patch b/app-admin/apachetop/files/apachetop-0.19.7-c++17.patch
new file mode 100644
index 000000000000..8ec6508b9e08
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.19.7-c++17.patch
@@ -0,0 +1,90 @@
+https://github.com/tessus/apachetop/pull/13
+
+From f89ae55bb09eb1a67fc73555d149fb85f82bfbd6 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 14 Feb 2023 03:34:36 +0000
+Subject: [PATCH] Fix C++17 compatibility (drop register keyword)
+
+register doesn't do anything in any reasonable C++ compiler anyway, but
+it was deprecated in C++14 and removed in C++17. Without this, apachetop
+will fail to compile with Clang 16 which defaults to -std=c++17.
+
+Bug: https://bugs.gentoo.org/894186
+--- a/src/inlines.cc
++++ b/src/inlines.cc
+@@ -4,10 +4,10 @@
+ #define ONE_EIGHTH 4
+ #define HIGH_BITS (~((unsigned int)(~0) >> ONE_EIGHTH))
+
+-inline unsigned int StringHash(register const char *str)
++inline unsigned int StringHash(const char *str)
+ {
+- register unsigned int val;
+- register unsigned int i;
++ unsigned int val;
++ unsigned int i;
+
+ for (val = 0; *str; str++)
+ {
+@@ -19,9 +19,9 @@ inline unsigned int StringHash(register const char *str)
+ return val;
+ }
+
+-inline unsigned int QuickHash(register const char *str)
++inline unsigned int QuickHash(const char *str)
+ {
+- register unsigned int val, tmp;
++ unsigned int val, tmp;
+
+ for(val = 0 ; *str ; str++)
+ {
+@@ -32,7 +32,7 @@ inline unsigned int QuickHash(register const char *str)
+ return val;
+ }
+
+-inline unsigned long TTHash(register const char *str)
++inline unsigned long TTHash(const char *str)
+ {
+ unsigned long hash = 5381;
+ int c;
+--- a/src/ohtbl.cc
++++ b/src/ohtbl.cc
+@@ -13,7 +13,7 @@ static int primes[] = {101, 241, 499, 1009, 2003, 3001, 4001, 5003,
+
+ int OAHash::getNextPrime(int size)
+ {
+- register int *prime;
++ int *prime;
+ for (prime = &primes[0] ; *prime ; prime++)
+ if (*prime > size)
+ return *prime;
+@@ -51,7 +51,7 @@ void OAHash::destroy(void)
+
+ void *OAHash::insert(char *key, void *data)
+ {
+- register unsigned int p, i;
++ unsigned int p, i;
+ void *d;
+
+ // Do not exceed the number of positions in the table.
+@@ -81,7 +81,7 @@ void *OAHash::insert(char *key, void *data)
+
+ int OAHash::remove(char *key)
+ {
+- register unsigned int p, i;
++ unsigned int p, i;
+
+ for (i = 0; i < positions; ++i)
+ {
+@@ -108,7 +108,7 @@ int OAHash::remove(char *key)
+
+ void *OAHash::lookup(char *key)
+ {
+- register unsigned int p, i;
++ unsigned int p, i;
+
+ for (i = 0; i < positions; ++i)
+ {
+--
+2.39.1
+
diff --git a/app-admin/apachetop/metadata.xml b/app-admin/apachetop/metadata.xml
index 585b0dc75dda..3e1e79272826 100644
--- a/app-admin/apachetop/metadata.xml
+++ b/app-admin/apachetop/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
- </pkgmetadata>
+ <upstream>
+ <remote-id type="github">tessus/apachetop</remote-id>
+ </upstream>
+</pkgmetadata>