summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.67.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index bc4c2e211b01..163bebef3e1e 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.32.59.gh.tar.gz 2660092 BLAKE2B 560bd7b69822af18f33e91d7586da20b6
DIST aws-cli-1.32.64.gh.tar.gz 2672156 BLAKE2B 6707984b03e004ed8672b35694c9e4be7d2543c040a64778c0ad43a4e011f07506eb5e3f9791a5b0e23bc5bd222b625daa078f9e42cfbf6d71b7887d675c1a5a SHA512 f39472bb1ad75cbfc4bf775aee9a003a884d7423e10d9ff96f90ebe7dbd97c0db4bbd4d52f1d918372ec880d1dea8f5cf82db31118a7c29973d42149064fd8a3
DIST aws-cli-1.32.65.gh.tar.gz 2672697 BLAKE2B 209f59887a7b7841ab3e9d502365b47f390516351cb055c8e89e10a1d83e259c9938a0a967d8b436814c637ed88ba853e75813b7ab8d7632d97fe6020392638d SHA512 924bb324ac513d3228d7e287b0a55537a1b0c53615673516edd69f2743d67b7746976c23fe6a455e0b265eee957dceaa750e556ede98f2f530e2a3373713817c
DIST aws-cli-1.32.66.gh.tar.gz 2674255 BLAKE2B a636728892756c9ae0837f470f74fb9a231302962a3ffe3c68ffeafa082342bbab8f4a32268c45a56ba0a34b3d5ca3e1f2e9ec53687515354b20af7accdae142 SHA512 f46da9511837956ff9584b25fd563f78fd02865b3f165e3d641bf725305bca4ae78865570c9f4ff92cdf36f9c25bd59f2543278781a09d95d07fb343cb9c535f
+DIST aws-cli-1.32.67.gh.tar.gz 2674997 BLAKE2B e852fbb594aad6f3879ffdcbee5135b7cc635a13fc4f12d05f9862cec43bcfe26701171da1baae0e3f8324534cd0bcb8ce7857a9d1add888066a24fc44f8bc02 SHA512 f619e46c75efa684219451a5adb89adcaccc88b149b8c240d3405507887ee734779d7097bb80a4f0e1d973f544f8b3743c6900c7e3f19e4b3cf1793da880748f
diff --git a/app-admin/awscli/awscli-1.32.67.ebuild b/app-admin/awscli/awscli-1.32.67.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.67.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}