summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.83.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 4964fa381d1c..1f6d9ba5321c 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.32.79.gh.tar.gz 2685785 BLAKE2B 3bbfad927d9d882e6b502f47919ce963d
DIST aws-cli-1.32.80.gh.tar.gz 2685662 BLAKE2B 9dd199937159943c419d4df98badee5253c9910c2d392fd843ff63d8edca6f71309c97221b623c7f0e2140a615cf804f69048024d6fbefea75d0da78cdafdfc1 SHA512 f30fc5a9f1890ef3d313e527d886588720d7ba039a44975c7600ea0bb326b542eb3897341cc832d68e759c95bbb2de8f8cc0ecfbf9c1c1b7e4d00dd9c7fd3213
DIST aws-cli-1.32.81.gh.tar.gz 2687946 BLAKE2B 09b672ceb60ba98c49bc7d747ce3639e40e0add35f583de7e42cea5e885fd833bd91c6eb4c94630c7151c914cebe28ee1327472a736d46ae3594e3a558db4e81 SHA512 f94f7147a946bfeb7414d08c7144ce6b452eb68bc9d42c686724824c5e8d77b012a5496778bfdf7cb15114065f3227e456df22327eeda505bb49c6da46934c34
DIST aws-cli-1.32.82.gh.tar.gz 2688583 BLAKE2B a77a64894949c5e06e6047423ed566ba285ca82bc31c289f81e1f11410b909b053112771789fcc1ed4cf20946993c35ff217f18d0ca57f333a621337b41eb05b SHA512 715a28b754f420264633eb88abd317317a71fa2f730a905172c166652cdc4ccc16ad300754b26e0016268b967039fb1680caee9be3016e9f80b9f5777d2adfd6
+DIST aws-cli-1.32.83.gh.tar.gz 2690517 BLAKE2B 551e8c485498c83d7d6ab53aa33e4dc73aeb13c4721fa2c76a5cf3769579a3e0514c7e32b3bde9431e7b19ad90607b6b7edf8bdffe9559e4389ee918cdc3979b SHA512 41335a7f3495087ed6c7a9aae0dc91d185bea7bfaec538ce9059014b26cd648f61ca5997de0e43d53300c91d6478c7a40e4e0d206e82fc3534f83d8f5ff91e69
diff --git a/app-admin/awscli/awscli-1.32.83.ebuild b/app-admin/awscli/awscli-1.32.83.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.83.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}