summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cli53')
-rw-r--r--app-admin/cli53/Manifest2
-rw-r--r--app-admin/cli53/cli53-0.8.18.ebuild32
-rw-r--r--app-admin/cli53/metadata.xml12
3 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/cli53/Manifest b/app-admin/cli53/Manifest
new file mode 100644
index 000000000000..c3a46ff0f967
--- /dev/null
+++ b/app-admin/cli53/Manifest
@@ -0,0 +1,2 @@
+DIST cli53-0.8.18-deps.tar.xz 53675196 BLAKE2B 6c06c21ce134a09341ab392921e4d0ad3bf13816e1b29e0374c2341418f649e079e3b216bd012d85c1fb802e820ecdfa6961d3cd58b838cdb10a1a6da6c7c5b0 SHA512 2028385362f81bcec178d7a232b1705e9501e44237f43eef935b7f27c937b889e60fb54be8b72280cae5775bc41c2346a15609a5d0ef5447ea4fa4885ffe052a
+DIST cli53-0.8.18.tar.gz 39059 BLAKE2B 993b1431130ce6bf9448ff0ca3c0bf09f4875b0a19df311160e940241b2127ee78c6d11eeeb3ca007763a54511951d3dca8f9e9585661e765c83bc340c38b7b4 SHA512 0bacbf10ce7fcbd359c16ff66ec5d415b4d9776e5a138847851c32715c90514b2ae2152a7b3e28a3a3b533b8d0b85d586faa7f62dc932fcd089ddfc706906a11
diff --git a/app-admin/cli53/cli53-0.8.18.ebuild b/app-admin/cli53/cli53-0.8.18.ebuild
new file mode 100644
index 000000000000..2a740a8d5388
--- /dev/null
+++ b/app-admin/cli53/cli53-0.8.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit go-module
+
+DESCRIPTION="A command-line tool for Amazon Route 53"
+HOMEPAGE="https://github.com/barnybug/cli53"
+SRC_URI="https://github.com/barnybug/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD BSD-2 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# gucumber is required to run tests which is not yet packaged
+RESTRICT="strip test"
+
+DEPEND=">=dev-lang/go-1.14"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ GOBIN="${S}/bin" \
+ emake install
+}
+
+src_install() {
+ dobin bin/${PN}
+ einstalldocs
+}
diff --git a/app-admin/cli53/metadata.xml b/app-admin/cli53/metadata.xml
new file mode 100644
index 000000000000..7767fea69549
--- /dev/null
+++ b/app-admin/cli53/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/barnybug/cli53/issues</bugs-to>
+ <remote-id type="github">barnybug/cli53</remote-id>
+ </upstream>
+</pkgmetadata>