summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/consul/consul-0.5.2-r1.ebuild')
-rw-r--r--app-admin/consul/consul-0.5.2-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-admin/consul/consul-0.5.2-r1.ebuild b/app-admin/consul/consul-0.5.2-r1.ebuild
index f48f76037eda..e95e2e7a6b17 100644
--- a/app-admin/consul/consul-0.5.2-r1.ebuild
+++ b/app-admin/consul/consul-0.5.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit golang-base systemd user
+inherit git-r3 golang-base systemd user
GO_PN="github.com/hashicorp/consul"
@@ -100,7 +100,7 @@ src_unpack() {
cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
while read -r path; do
rm -rf "${GOROOT}/src/${path#${WORKDIR}/src}" \
- "${GOROOT}/pkg/linux_${ARCH}/${path#${WORKDIR}/src}" || die
+ "${GOROOT}/pkg/$(go env GOOS)_$(go env GOARCH)/${path#${WORKDIR}/src}" || die
done < <(find "${WORKDIR}"/src -maxdepth 3 -mindepth 3 -type d)
}
@@ -157,13 +157,13 @@ src_install() {
while read -r -d '' x; do
x=${x#${WORKDIR}/src}
- [[ -d ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x} ||
- -f ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x}.a ]] && continue
+ [[ -d ${WORKDIR}/pkg/$(go env GOOS)_$(go env GOARCH)/${x} ||
+ -f ${WORKDIR}/pkg/$(go env GOOS)_$(go env GOARCH)/${x}.a ]] && continue
rm -rf "${WORKDIR}"/src/${x}
done < <(find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type d -print0)
insopts -m0644 -p # preserve timestamps for bug 551486
- insinto /usr/lib/go/pkg/${KERNEL}_${ARCH}/${GO_PN%/*}
- doins -r "${WORKDIR}"/pkg/${KERNEL}_${ARCH}/${GO_PN}
+ insinto /usr/lib/go/pkg/$(go env GOOS)_$(go env GOARCH)/${GO_PN%/*}
+ doins -r "${WORKDIR}"/pkg/$(go env GOOS)_$(go env GOARCH)/${GO_PN}
insinto /usr/lib/go/src/${GO_PN%/*}
doins -r "${WORKDIR}"/src/${GO_PN}
}