summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/consul')
-rw-r--r--app-admin/consul/Manifest1
-rw-r--r--app-admin/consul/consul-1.15.2.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/app-admin/consul/Manifest b/app-admin/consul/Manifest
index 35e6a758c762..9b22bf37a316 100644
--- a/app-admin/consul/Manifest
+++ b/app-admin/consul/Manifest
@@ -1,2 +1 @@
-DIST consul-1.15.2-vendor.tar.gz 43070821 BLAKE2B 39e375cf6fcb17e9a633aa7048588560f8efc93aacad7a332210d509d0b50a74e525be5e56ad9e0aa642b43f68362b8e28beb264c4365a96dd98eab6f4d296d7 SHA512 b00cd569dee83c7850fc13e5591c55dd2903242349ec747cc7ac8f18ebd207858148521c62a1da914610988f95cd543fcc5f5771a1c072c09521a8af0a474ba6
DIST consul-1.15.3-vendor.tar.gz 43434721 BLAKE2B 7595c98cdecf67e9fb412d8fea1d790dc6b1c29f7bc427e1d0872045a05f8873dc6107f196cea04fe0a2f2553d4fbb1f8d501e5e107b2bea3ae841e5d94eda64 SHA512 b69e3a7c1ebb01c7a64f2c6167e63e8a530b81be9aad8b591d0a71f512f5157ba9a564b46f9effe52a5abd3ae61732e7af10c5ba002110f745eb3d94ebcec256
diff --git a/app-admin/consul/consul-1.15.2.ebuild b/app-admin/consul/consul-1.15.2.ebuild
deleted file mode 100644
index 0b02a570806c..000000000000
--- a/app-admin/consul/consul-1.15.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd
-
-DESCRIPTION="A tool for service discovery, monitoring and configuration"
-HOMEPAGE="https://www.consul.io"
-GIT_COMMIT="5e08e229dbdaed5adf3ca99afe9df247c51507da"
-
-SRC_URI="https://github.com/zmedico/consul/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
-
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
-RESTRICT="test"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-BDEPEND="dev-go/gox"
-COMMON_DEPEND="
- acct-group/consul
- acct-user/consul"
- DEPEND="${COMMON_DEPEND}"
- RDEPEND="${COMMON_DEPEND}"
-
-S=${WORKDIR}/${P}-vendor
-
-src_prepare() {
- default
- sed -e 's|^GIT_DATE=.*|GIT_DATE=2023-03-30T17:51:19Z|' -i GNUmakefile || die
-}
-
-src_compile() {
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- GIT_DESCRIBE="v${PV}" \
- GIT_DIRTY="" \
- GIT_COMMIT="${GIT_COMMIT}" \
- emake dev-build
-}
-
-src_install() {
- dobin bin/consul
-
- keepdir /etc/consul.d
- insinto /etc/consul.d
- doins "${FILESDIR}/"*.json.example
-
- keepdir /var/log/consul
- fowners consul:consul /var/log/consul
-
- newinitd "${FILESDIR}/consul.initd" "${PN}"
- newconfd "${FILESDIR}/consul.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/consul.service"
-}