summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cronolog/cronolog-1.6.2-r7.ebuild')
-rw-r--r--app-admin/cronolog/cronolog-1.6.2-r7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/cronolog/cronolog-1.6.2-r7.ebuild b/app-admin/cronolog/cronolog-1.6.2-r7.ebuild
new file mode 100644
index 000000000000..32788154300e
--- /dev/null
+++ b/app-admin/cronolog/cronolog-1.6.2-r7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Log rotation software"
+HOMEPAGE="https://github.com/fordmason/cronolog"
+SRC_URI="http://cronolog.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-patches
+ # rename and move into ${PV}-patches after -r3 removal
+ "${FILESDIR}"/${P}-umask.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}