summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/doctl')
-rw-r--r--app-admin/doctl/Manifest3
-rw-r--r--app-admin/doctl/doctl-1.78.0.ebuild (renamed from app-admin/doctl/doctl-1.57.0.ebuild)21
-rw-r--r--app-admin/doctl/doctl-1.79.0.ebuild43
-rw-r--r--app-admin/doctl/doctl-9999.ebuild21
-rw-r--r--app-admin/doctl/metadata.xml2
5 files changed, 66 insertions, 24 deletions
diff --git a/app-admin/doctl/Manifest b/app-admin/doctl/Manifest
index 1dc7041d6b22..f2e3e2f3aa87 100644
--- a/app-admin/doctl/Manifest
+++ b/app-admin/doctl/Manifest
@@ -1 +1,2 @@
-DIST doctl-1.57.0.tar.gz 5195498 BLAKE2B 17273e9f8f63464aa2ba6c6d48dfabd78b0bdeb7156dc315d1970fb0052710c7a4b37f1d5e2a7a60211f2ab166c0926de438959d853639a8c329ec39b3ee0577 SHA512 0c868c5732a48367a93bf2b884689dbd917ba6690c82516495862546bc31d58d44aab192bd3b3543f951e9fa9b7289e99fbdf828c017af68496b84f1585a5f6b
+DIST doctl-1.78.0.tar.gz 5658172 BLAKE2B 3213219b1cfbc395c742a59a6bee1c6232f222455ac126de9ce51470a56ebaa9680de4d332cd31580a7ddb9f748b19a8abadef17ff6ea4265dffc2c42b1bb16d SHA512 193fe775885c78312eb6ba14bd34d109ee31acf41cfe68dbacbf6ab19864509b774c658aecf7a61d470598ca89829a6737ea6796eb970b3075d8f37aef747dbe
+DIST doctl-1.79.0.tar.gz 5661873 BLAKE2B 276cf8355f982070e2a44306f0d2bca5c269eccab3d67fe8b1b68171d393bacfb857e78fc66e036b0c039fa4bcf26505c029a1ba5ccebfeebf81d4dc3f51d82f SHA512 8257fc8d32ee097f78420138bd12572235dd7a6cead65fe1a666a9686d2f31add50a85a99fed45aae641b583b47b079a0ea3ce6e9e017c6ecfc7dfc14f7b5abd
diff --git a/app-admin/doctl/doctl-1.57.0.ebuild b/app-admin/doctl/doctl-1.78.0.ebuild
index c1ed045f556d..3f5680240a83 100644
--- a/app-admin/doctl/doctl-1.57.0.ebuild
+++ b/app-admin/doctl/doctl-1.78.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit bash-completion-r1 go-module
+inherit bash-completion-r1 edo go-module
DESCRIPTION="A command line tool for DigitalOcean services"
HOMEPAGE="https://github.com/digitalocean/doctl"
@@ -12,24 +12,23 @@ SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
src_compile() {
LDFLAGS="-X github.com/digitalocean/doctl.Major=$(ver_cut 1)
-X github.com/digitalocean/doctl.Minor=$(ver_cut 2)
-X github.com/digitalocean/doctl.Patch=$(ver_cut 3-)
-X github.com/digitalocean/doctl.Label=release"
- GOFLAGS="-v -x -mod=vendor" \
- go build -ldflags "$LDFLAGS" ./cmd/... || die "build failed"
+ GOFLAGS="-v -x -mod=vendor" ego build -ldflags "$LDFLAGS" ./cmd/...
- ./doctl completion bash > doctl.bash || die "completion for bash failed"
- ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
- ./doctl completion fish > doctl.fish || die "completion for fish failed"
+ local completion
+ for completion in bash zsh fish ; do
+ edo ./doctl completion ${completion} > doctl.${completion} \
+ || die "completion for ${completion} failed"
+ done
}
src_test() {
- GOFLAGS="-v -x -mod=vendor" \
- go test -work ./do/... ./pkg/... . || die "test failed"
+ GOFLAGS="-v -x -mod=vendor" ego test -work ./do/... ./pkg/... .
}
src_install() {
diff --git a/app-admin/doctl/doctl-1.79.0.ebuild b/app-admin/doctl/doctl-1.79.0.ebuild
new file mode 100644
index 000000000000..3f5680240a83
--- /dev/null
+++ b/app-admin/doctl/doctl-1.79.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 edo go-module
+
+DESCRIPTION="A command line tool for DigitalOcean services"
+HOMEPAGE="https://github.com/digitalocean/doctl"
+SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ LDFLAGS="-X github.com/digitalocean/doctl.Major=$(ver_cut 1)
+ -X github.com/digitalocean/doctl.Minor=$(ver_cut 2)
+ -X github.com/digitalocean/doctl.Patch=$(ver_cut 3-)
+ -X github.com/digitalocean/doctl.Label=release"
+ GOFLAGS="-v -x -mod=vendor" ego build -ldflags "$LDFLAGS" ./cmd/...
+
+ local completion
+ for completion in bash zsh fish ; do
+ edo ./doctl completion ${completion} > doctl.${completion} \
+ || die "completion for ${completion} failed"
+ done
+}
+
+src_test() {
+ GOFLAGS="-v -x -mod=vendor" ego test -work ./do/... ./pkg/... .
+}
+
+src_install() {
+ einstalldocs
+ dobin doctl
+
+ newbashcomp doctl.bash doctl
+ insinto /usr/share/zsh/site-functions
+ newins doctl.zsh _doctl
+ insinto /usr/share/fish/completion
+ newins doctl.fish doctl
+}
diff --git a/app-admin/doctl/doctl-9999.ebuild b/app-admin/doctl/doctl-9999.ebuild
index 654c28a745f8..9837f24928f9 100644
--- a/app-admin/doctl/doctl-9999.ebuild
+++ b/app-admin/doctl/doctl-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
EGIT_REPO_URI="https://github.com/digitalocean/${PN}.git"
-inherit bash-completion-r1 git-r3 go-module
+inherit bash-completion-r1 edo git-r3 go-module
DESCRIPTION="A command line tool for DigitalOcean services"
HOMEPAGE="https://github.com/digitalocean/doctl"
@@ -14,7 +14,6 @@ SRC_URI=""
LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
SLOT="0"
KEYWORDS=""
-IUSE=""
src_unpack() {
git-r3_src_unpack
@@ -23,17 +22,17 @@ src_unpack() {
src_compile() {
LDFLAGS="-X github.com/digitalocean/doctl.Build=$(git rev-parse --short HEAD)
-X github.com/digitalocean/doctl.Label=dev"
- GOFLAGS="-v -x -mod=vendor" \
- go build -ldflags "$LDFLAGS" ./cmd/... || die "build failed"
+ GOFLAGS="-v -x -mod=vendor" ego build -ldflags "$LDFLAGS" ./cmd/...
- ./doctl completion bash > doctl.bash || die "completion for bash failed"
- ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
- ./doctl completion fish > doctl.fish || die "completion for fish failed"
+ local completion
+ for completion in bash zsh fish ; do
+ edo ./doctl completion ${completion} > doctl.${completion} \
+ || die "completion for ${completion} failed"
+ done
}
src_test() {
- GOFLAGS="-v -x -mod=vendor" \
- go test -work ./do/... ./pkg/... . || die "test failed"
+ GOFLAGS="-v -x -mod=vendor" ego test -work ./do/... ./pkg/... .
}
src_install() {
diff --git a/app-admin/doctl/metadata.xml b/app-admin/doctl/metadata.xml
index a12cd19ca0c5..55a27c525ef1 100644
--- a/app-admin/doctl/metadata.xml
+++ b/app-admin/doctl/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
<email>spiderx@spiderx.dp.ua</email>