summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gopass-jsonapi/gopass-jsonapi-1.15.13.ebuild')
-rw-r--r--app-admin/gopass-jsonapi/gopass-jsonapi-1.15.13.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-admin/gopass-jsonapi/gopass-jsonapi-1.15.13.ebuild b/app-admin/gopass-jsonapi/gopass-jsonapi-1.15.13.ebuild
new file mode 100644
index 000000000000..699540bb5843
--- /dev/null
+++ b/app-admin/gopass-jsonapi/gopass-jsonapi-1.15.13.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Gopass Browser Bindings"
+HOMEPAGE="https://github.com/gopasspw/gopass-jsonapi"
+SRC_URI="https://github.com/gopasspw/gopass-jsonapi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=dev-lang/go-1.16"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.15.3-skip-test.patch"
+)