summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gopass/gopass-1.8.6.ebuild')
-rw-r--r--app-admin/gopass/gopass-1.8.6.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/app-admin/gopass/gopass-1.8.6.ebuild b/app-admin/gopass/gopass-1.8.6.ebuild
deleted file mode 100644
index 5ca88b63636f..000000000000
--- a/app-admin/gopass/gopass-1.8.6.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/gopasspw/gopass"
-
-inherit golang-vcs-snapshot golang-build bash-completion-r1
-
-DESCRIPTION="a simple but powerful password manager for the terminal"
-HOMEPAGE="https://www.gopass.pw/"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=dev-lang/go-1.11"
-RDEPEND="
- dev-vcs/git
- >=app-crypt/gnupg-2
-"
-
-src_install() {
- dobin gopass
-
- local DOCS=( src/${EGO_PN}/{CHANGELOG,CONTRIBUTING}.md src/${EGO_PN}/docs/*.md )
- einstalldocs
-
- # install fish completion
- ./gopass completion fish > "${T}"/${PN}.fish || die
- insinto /usr/share/fish/vendor_completions.d
- doins "${T}"/${PN}.fish
-
- # install bash completion
- ./gopass completion bash > "${T}"/${PN} || die
- dobashcomp "${T}"/${PN}
-
- # install zsh completion
- ./gopass completion zsh > "${T}"/${PN}.zsh || die
- insinto /usr/share/zsh/site-functions
- newins "${T}"/${PN}.zsh _${PN}
-}