summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/graylog')
-rw-r--r--app-admin/graylog/Manifest2
-rw-r--r--app-admin/graylog/graylog-4.1.12.ebuild60
-rw-r--r--app-admin/graylog/graylog-4.2.6.ebuild60
3 files changed, 122 insertions, 0 deletions
diff --git a/app-admin/graylog/Manifest b/app-admin/graylog/Manifest
index fd5fed840e9b..b433bb45621b 100644
--- a/app-admin/graylog/Manifest
+++ b/app-admin/graylog/Manifest
@@ -1 +1,3 @@
DIST graylog-4.1.11.tgz 197190151 BLAKE2B 10e8006c967861aec826768ada2c965729e992eba3701e1475ad68aec5c31ce35c0bbb41ffa8f4a0735cdeb85c8502d462f9925918d568ccbc669e935bc31de4 SHA512 4f903ec470d60836be720f59c24b8454d0689b961af84623eaeb061d4e719cfc4fc0bcfde7074de8e6a3c6d1e3f608cdc6713b50f2d9031d298660c08cf4e219
+DIST graylog-4.1.12.tgz 197206216 BLAKE2B 844c305bf8aad7289f7e8b5e9d6b25b2a0c360182be30e5f9c72d7dfce782f4bcac703a543fcca92e4d5fe281dbf6d717f0c12ea67cbed193d8e1fc93405c896 SHA512 dc27e82200f1e9dd828b99dd5947f198a575fb819a490f450badad47449b9a38f2ee6977511397eb84f2430a44a6f598fd426ec42f5e1ad00291314dbc963377
+DIST graylog-4.2.6.tgz 197322595 BLAKE2B daa5466e9ab06b0af92f17abdaf77d604212c25bef3e6ea7b45e073ff54a27be0177b65956a8ec2b48814d490f5fbfa116ec278aad88ec727cd0d3aa89732073 SHA512 63ce15d556fcf38c501c1676b68e2e7f06442f57c0c5993a3ed5918deebac40cb47d7b4aaeb697f95257774eecedce2b5f7344e3799ba333a46a1bf1d5b48412
diff --git a/app-admin/graylog/graylog-4.1.12.ebuild b/app-admin/graylog/graylog-4.1.12.ebuild
new file mode 100644
index 000000000000..766a2362711f
--- /dev/null
+++ b/app-admin/graylog/graylog-4.1.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://www.graylog.org"
+SRC_URI="https://downloads.graylog.org/releases/graylog/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="acct-group/graylog
+ acct-user/graylog
+ >=virtual/jdk-1.8:*"
+
+DOCS=(
+ README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+src_prepare() {
+ default
+
+ # gentoo specific paths
+ sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+ s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g;" \
+ graylog.conf.example || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/graylog
+ doins graylog.conf.example
+
+ insinto "${GRAYLOG_INSTALL_DIR}"
+ doins graylog.jar
+ doins -r plugin
+
+ keepdir "${GRAYLOG_DATA_DIR}"
+
+ newconfd "${FILESDIR}/graylog.confd" graylog
+ newinitd "${FILESDIR}/graylog.initd" graylog
+}
+
+pkg_postinst() {
+ elog "Please visit the website for product changes:"
+ elog "https://docs.graylog.org/docs/changelog"
+ elog
+ ewarn "Graylog does not depend on need.net any more (#439092)."
+ ewarn
+ ewarn "Please configure rc_need according to your binding address in:"
+ ewarn "/etc/conf.d/graylog"
+}
diff --git a/app-admin/graylog/graylog-4.2.6.ebuild b/app-admin/graylog/graylog-4.2.6.ebuild
new file mode 100644
index 000000000000..766a2362711f
--- /dev/null
+++ b/app-admin/graylog/graylog-4.2.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://www.graylog.org"
+SRC_URI="https://downloads.graylog.org/releases/graylog/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="acct-group/graylog
+ acct-user/graylog
+ >=virtual/jdk-1.8:*"
+
+DOCS=(
+ README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+src_prepare() {
+ default
+
+ # gentoo specific paths
+ sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+ s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g;" \
+ graylog.conf.example || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/graylog
+ doins graylog.conf.example
+
+ insinto "${GRAYLOG_INSTALL_DIR}"
+ doins graylog.jar
+ doins -r plugin
+
+ keepdir "${GRAYLOG_DATA_DIR}"
+
+ newconfd "${FILESDIR}/graylog.confd" graylog
+ newinitd "${FILESDIR}/graylog.initd" graylog
+}
+
+pkg_postinst() {
+ elog "Please visit the website for product changes:"
+ elog "https://docs.graylog.org/docs/changelog"
+ elog
+ ewarn "Graylog does not depend on need.net any more (#439092)."
+ ewarn
+ ewarn "Please configure rc_need according to your binding address in:"
+ ewarn "/etc/conf.d/graylog"
+}