summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepassxc/keepassxc-9999.ebuild')
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 1b5f2654570d..85eaad62e18d 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -65,6 +65,7 @@ src_prepare() {
}
src_configure() {
+
local mycmakeargs=(
-DWITH_GUI_TESTS=OFF
-DWITH_TESTS="$(usex test)"
@@ -75,6 +76,9 @@ src_configure() {
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_YUBIKEY="$(usex yubikey)"
)
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ fi
cmake-utils_src_configure
}