summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/Manifest3
-rw-r--r--app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch13
-rw-r--r--app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild (renamed from app-admin/keepassxc/keepassxc-2.7.1-r1.ebuild)44
-rw-r--r--app-admin/keepassxc/keepassxc-2.7.8.ebuild113
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild57
-rw-r--r--app-admin/keepassxc/metadata.xml2
6 files changed, 194 insertions, 38 deletions
diff --git a/app-admin/keepassxc/Manifest b/app-admin/keepassxc/Manifest
index f0479c7ab83a..40112daa3c5b 100644
--- a/app-admin/keepassxc/Manifest
+++ b/app-admin/keepassxc/Manifest
@@ -1 +1,2 @@
-DIST keepassxc-2.7.1.tar.gz 11168642 BLAKE2B 4708821c596e8fc736e086a700d5526be6d9c4cfcb270e3a0a8b73395e9ca3544cbb5973494b15d66e0b98264f4e79d9fa122961407211d346275a9aa1bd5cae SHA512 c2f780ba1f464b32f741d1c6e83734ff220de56dce382f3c38d940abf255d689559c13bff6ad565c38c18cfdb1d883aca52650dba0486e3e28bb4ef872253cc9
+DIST keepassxc-2.7.7-src.tar.xz 9734460 BLAKE2B d94c42334bbfde46f14f4b14612f4297c500da76ba8a82de26c4a450ee1cacb9a15517a84ef445441651dc33a71f9ca7bca63bb04d0a4e8eeb0380eded6e5477 SHA512 fd82e377bf6e57623c65f2bdd463ea59c6465fbe009552e1030ce0fe9d9177fc448b7b36a90a0da9ed2a2ed161c017d13cef618ae785f89110c038e1d9396926
+DIST keepassxc-2.7.8-src.tar.xz 9764860 BLAKE2B edc5af2b7bd6173f8df4fa20fca54e78c40610d29b02ac9f9920382b8ead3ea293e22e578c353ffc1a374a23f1117a2595570d1de7053a1d36bcb40ed8eceb04 SHA512 c4767ced36d45855b83569d0fcbcfd384ef51d204dd703b006508d55cd7ac94ac36b5476f122fbe1dc6ec301a785e026722e8f0f961d5e339e10997a3871741a
diff --git a/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch b/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch
new file mode 100644
index 000000000000..ccee26cb5ba9
--- /dev/null
+++ b/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch
@@ -0,0 +1,13 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -231,10 +231,6 @@ if(WITH_XC_BROWSER)
+ LIBS ${TEST_LIBRARIES})
+ endif()
+
+-add_unit_test(NAME testcli SOURCES TestCli.cpp
+- LIBS testsupport cli ${TEST_LIBRARIES})
+-target_compile_definitions(testcli PRIVATE KEEPASSX_CLI_PATH="$<TARGET_FILE:keepassxc-cli>")
+-
+ if(WITH_GUI_TESTS)
+ add_subdirectory(gui)
+ endif(WITH_GUI_TESTS)
diff --git a/app-admin/keepassxc/keepassxc-2.7.1-r1.ebuild b/app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild
index bf2430003375..6d17e534e3b4 100644
--- a/app-admin/keepassxc/keepassxc-2.7.1-r1.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,32 +6,35 @@ EAPI=8
inherit cmake flag-o-matic xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
-HOMEPAGE="https://keepassxc.org"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
if [[ "${PV}" != *9999 ]] ; then
if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
else
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
fi
else
inherit git-r3
+
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
[[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
fi
LICENSE="LGPL-2.1 GPL-2 GPL-3"
SLOT="0"
-IUSE="autotype browser doc keeshare +network test yubikey"
+IUSE="X autotype browser doc keeshare +network test yubikey"
RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
RDEPEND="
app-crypt/argon2:=
- dev-libs/botan:2=
+ dev-libs/botan:3=
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -39,41 +42,49 @@ RDEPEND="
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
media-gfx/qrencode:=
sys-libs/readline:0=
- sys-libs/zlib:=
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
autotype? (
x11-libs/libX11
x11-libs/libXtst
)
- keeshare? ( sys-libs/zlib:=[minizip] )
yubikey? (
dev-libs/libusb:1
sys-apps/pcsc-lite
)
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
dev-qt/qttest:5
"
BDEPEND="
dev-qt/linguist-tools:5
- doc? ( dev-ruby/asciidoctor )
+ doc? (
+ dev-ruby/asciidoctor
+ )
"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
+
src_prepare() {
if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
printf '%s' "${PV}" > .version || die
fi
- cmake_src_prepare
+ cmake_src_prepare
}
src_configure() {
# https://github.com/keepassxreboot/keepassxc/issues/5801
- filter-flags -flto*
+ filter-lto
- local mycmakeargs=(
+ local -a mycmakeargs=(
# Gentoo users enable ccache via e.g. FEATURES=ccache or
# other means. We don't want the build system to enable it for us.
-DWITH_CCACHE=OFF
@@ -82,12 +93,15 @@ src_configure() {
-DWITH_XC_AUTOTYPE="$(usex autotype)"
-DWITH_XC_DOCS="$(usex doc)"
-DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
-DWITH_XC_FDOSECRETS=ON
-DWITH_XC_KEESHARE="$(usex keeshare)"
-DWITH_XC_NETWORKING="$(usex network)"
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_UPDATECHECK=OFF
-DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
)
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
diff --git a/app-admin/keepassxc/keepassxc-2.7.8.ebuild b/app-admin/keepassxc/keepassxc-2.7.8.ebuild
new file mode 100644
index 000000000000..11cc2ac9b84e
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-2.7.8.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
+
+if [[ "${PV}" = *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="develop"
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+else
+ if [[ "${PV}" == *_beta* ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+ fi
+
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
+
+RDEPEND="
+ app-crypt/argon2:=
+ dev-libs/botan:3=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-gfx/qrencode:=
+ sys-libs/readline:0=
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
+ autotype? (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qttest:5
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-ruby/asciidoctor
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
+
+src_prepare() {
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-lto
+
+ local -a mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_DOCS="$(usex doc)"
+ -DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
+ -DWITH_XC_FDOSECRETS=ON
+ -DWITH_XC_KEESHARE="$(usex keeshare)"
+ -DWITH_XC_NETWORKING="$(usex network)"
+ -DWITH_XC_SSHAGENT=ON
+ -DWITH_XC_UPDATECHECK=OFF
+ -DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
+ )
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=(
+ -DOVERRIDE_VERSION="${PV/_/-}"
+ )
+ fi
+ cmake_src_configure
+}
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 985aebc0d678..11cc2ac9b84e 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,21 +6,24 @@ EAPI=8
inherit cmake flag-o-matic xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
-HOMEPAGE="https://keepassxc.org"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
-if [[ "${PV}" != *9999 ]] ; then
+if [[ "${PV}" = *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="develop"
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+else
if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
else
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
fi
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
- [[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
+
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
LICENSE="LGPL-2.1 GPL-2 GPL-3"
@@ -32,7 +35,7 @@ REQUIRED_USE="autotype? ( X )"
RDEPEND="
app-crypt/argon2:=
- dev-libs/botan:2=
+ dev-libs/botan:3=
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -42,39 +45,47 @@ RDEPEND="
dev-qt/qtwidgets:5
media-gfx/qrencode:=
sys-libs/readline:0=
- sys-libs/zlib:=
- X? ( dev-qt/qtx11extras:5 )
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
autotype? (
x11-libs/libX11
x11-libs/libXtst
)
- keeshare? ( sys-libs/zlib:=[minizip] )
yubikey? (
dev-libs/libusb:1
sys-apps/pcsc-lite
)
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
dev-qt/qttest:5
"
BDEPEND="
dev-qt/linguist-tools:5
- doc? ( dev-ruby/asciidoctor )
+ doc? (
+ dev-ruby/asciidoctor
+ )
"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
+
src_prepare() {
if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
printf '%s' "${PV}" > .version || die
fi
- cmake_src_prepare
+ cmake_src_prepare
}
src_configure() {
# https://github.com/keepassxreboot/keepassxc/issues/5801
- filter-flags -flto*
+ filter-lto
- local mycmakeargs=(
+ local -a mycmakeargs=(
# Gentoo users enable ccache via e.g. FEATURES=ccache or
# other means. We don't want the build system to enable it for us.
-DWITH_CCACHE=OFF
@@ -83,6 +94,8 @@ src_configure() {
-DWITH_XC_AUTOTYPE="$(usex autotype)"
-DWITH_XC_DOCS="$(usex doc)"
-DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
-DWITH_XC_FDOSECRETS=ON
-DWITH_XC_KEESHARE="$(usex keeshare)"
-DWITH_XC_NETWORKING="$(usex network)"
@@ -92,7 +105,9 @@ src_configure() {
-DWITH_XC_X11="$(usex X)"
)
if [[ "${PV}" == *_beta* ]] ; then
- mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ mycmakeargs+=(
+ -DOVERRIDE_VERSION="${PV/_/-}"
+ )
fi
cmake_src_configure
}
diff --git a/app-admin/keepassxc/metadata.xml b/app-admin/keepassxc/metadata.xml
index a608739dade1..dc74e3197e66 100644
--- a/app-admin/keepassxc/metadata.xml
+++ b/app-admin/keepassxc/metadata.xml
@@ -14,7 +14,7 @@
<flag name="browser">Enables browser plugin support</flag>
<flag name="keeshare">Enable KeeShare sharing integration</flag>
<flag name="network">Enable network support</flag>
- <flag name="yubikey">Enable database unlocking via YubiKey.</flag>
+ <flag name="yubikey">Enable database unlocking via hardware keys supporting YubiKey-style HMAC-SHA1 protocol</flag>
</use>
<longdescription>
KeePassXC provides a safe location for your passwords and similar