summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/Manifest4
-rw-r--r--app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch13
-rw-r--r--app-admin/keepassxc/keepassxc-2.6.1.ebuild90
-rw-r--r--app-admin/keepassxc/keepassxc-2.6.2.ebuild90
-rw-r--r--app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild110
-rw-r--r--app-admin/keepassxc/keepassxc-2.7.8.ebuild113
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild85
-rw-r--r--app-admin/keepassxc/metadata.xml45
8 files changed, 316 insertions, 234 deletions
diff --git a/app-admin/keepassxc/Manifest b/app-admin/keepassxc/Manifest
index d0348241f3ea..40112daa3c5b 100644
--- a/app-admin/keepassxc/Manifest
+++ b/app-admin/keepassxc/Manifest
@@ -1,2 +1,2 @@
-DIST keepassxc-2.6.1-src.tar.xz 5715948 BLAKE2B 5490757fd939b572f2f281dc6ecfcd6afc7f9a5b2ebf3cc0c8ae4a95bb982ad755a9363f6133fb0f4ac2a2b5e0a6c66a7dba954911cb5baf70d447fc8d6089bf SHA512 9fb2d01d80e2b61c847c0544c280c1f3bfca671268e2dbbe78e0f3c1264f38125a3767ceb4591261f3586cd71f4fff47ecc6eacaecf1e707cea5e8907542313a
-DIST keepassxc-2.6.2-src.tar.xz 5720788 BLAKE2B c6bcc0af594c3b697d8e74752edb0389c80c72008bd57dcc36d9606462ea4bc9c6012a9f3f31702a9c0f88004fdc66f1ee4fbebd8a501227f4579ea8f3f1078f SHA512 b297edc4fae32b65430802094bd63dc301addae36859365a3009899d5bc20b32934e174ea56bf3fd1ee633a263ab36b577cba5aaa75bf4ad597f44606f7b5fd1
+DIST keepassxc-2.7.7-src.tar.xz 9734460 BLAKE2B d94c42334bbfde46f14f4b14612f4297c500da76ba8a82de26c4a450ee1cacb9a15517a84ef445441651dc33a71f9ca7bca63bb04d0a4e8eeb0380eded6e5477 SHA512 fd82e377bf6e57623c65f2bdd463ea59c6465fbe009552e1030ce0fe9d9177fc448b7b36a90a0da9ed2a2ed161c017d13cef618ae785f89110c038e1d9396926
+DIST keepassxc-2.7.8-src.tar.xz 9764860 BLAKE2B edc5af2b7bd6173f8df4fa20fca54e78c40610d29b02ac9f9920382b8ead3ea293e22e578c353ffc1a374a23f1117a2595570d1de7053a1d36bcb40ed8eceb04 SHA512 c4767ced36d45855b83569d0fcbcfd384ef51d204dd703b006508d55cd7ac94ac36b5476f122fbe1dc6ec301a785e026722e8f0f961d5e339e10997a3871741a
diff --git a/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch b/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch
new file mode 100644
index 000000000000..ccee26cb5ba9
--- /dev/null
+++ b/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch
@@ -0,0 +1,13 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -231,10 +231,6 @@ if(WITH_XC_BROWSER)
+ LIBS ${TEST_LIBRARIES})
+ endif()
+
+-add_unit_test(NAME testcli SOURCES TestCli.cpp
+- LIBS testsupport cli ${TEST_LIBRARIES})
+-target_compile_definitions(testcli PRIVATE KEEPASSX_CLI_PATH="$<TARGET_FILE:keepassxc-cli>")
+-
+ if(WITH_GUI_TESTS)
+ add_subdirectory(gui)
+ endif(WITH_GUI_TESTS)
diff --git a/app-admin/keepassxc/keepassxc-2.6.1.ebuild b/app-admin/keepassxc/keepassxc-2.6.1.ebuild
deleted file mode 100644
index d85bd1e36b75..000000000000
--- a/app-admin/keepassxc/keepassxc-2.6.1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
-HOMEPAGE="https://keepassxc.org"
-
-if [[ "${PV}" != 9999 ]] ; then
- if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${P/_/-}"
- else
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
- KEYWORDS="amd64 ~arm64 ~ppc64 x86"
- fi
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
-fi
-
-LICENSE="LGPL-2.1 GPL-2 GPL-3"
-SLOT="0"
-IUSE="autotype browser ccache keeshare +network test yubikey"
-
-RDEPEND="
- app-crypt/argon2:=
- dev-libs/libgcrypt:=
- >=dev-libs/libsodium-1.0.12:=
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- media-gfx/qrencode:=
- sys-libs/readline:0=
- sys-libs/zlib:=
- autotype? (
- dev-qt/qtx11extras:5
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXtst
- )
- keeshare? ( dev-libs/quazip )
- yubikey? ( sys-auth/ykpers )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-qt/linguist-tools:5
- dev-qt/qttest:5
-"
-BDEPEND="
- ccache? ( dev-util/ccache )
-"
-
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- use test || \
- sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_CCACHE="$(usex ccache)"
- -DWITH_GUI_TESTS=OFF
- -DWITH_TESTS="$(usex test)"
- -DWITH_XC_AUTOTYPE="$(usex autotype)"
- -DWITH_XC_DOCS=OFF
- -DWITH_XC_BROWSER="$(usex browser)"
- -DWITH_XC_FDOSECRETS=ON
- -DWITH_XC_KEESHARE="$(usex keeshare)"
- -DWITH_XC_NETWORKING="$(usex network)"
- -DWITH_XC_SSHAGENT=ON
- -DWITH_XC_UPDATECHECK=OFF
- -DWITH_XC_YUBIKEY="$(usex yubikey)"
- )
- if [[ "${PV}" == *_beta* ]] ; then
- mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
- fi
- cmake_src_configure
-}
diff --git a/app-admin/keepassxc/keepassxc-2.6.2.ebuild b/app-admin/keepassxc/keepassxc-2.6.2.ebuild
deleted file mode 100644
index 0511c16e1277..000000000000
--- a/app-admin/keepassxc/keepassxc-2.6.2.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
-HOMEPAGE="https://keepassxc.org"
-
-if [[ "${PV}" != 9999 ]] ; then
- if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${P/_/-}"
- else
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
- fi
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
-fi
-
-LICENSE="LGPL-2.1 GPL-2 GPL-3"
-SLOT="0"
-IUSE="autotype browser ccache keeshare +network test yubikey"
-
-RDEPEND="
- app-crypt/argon2:=
- dev-libs/libgcrypt:=
- >=dev-libs/libsodium-1.0.12:=
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- media-gfx/qrencode:=
- sys-libs/readline:0=
- sys-libs/zlib:=
- autotype? (
- dev-qt/qtx11extras:5
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXtst
- )
- keeshare? ( dev-libs/quazip )
- yubikey? ( sys-auth/ykpers )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-qt/linguist-tools:5
- dev-qt/qttest:5
-"
-BDEPEND="
- ccache? ( dev-util/ccache )
-"
-
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- use test || \
- sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_CCACHE="$(usex ccache)"
- -DWITH_GUI_TESTS=OFF
- -DWITH_TESTS="$(usex test)"
- -DWITH_XC_AUTOTYPE="$(usex autotype)"
- -DWITH_XC_DOCS=OFF
- -DWITH_XC_BROWSER="$(usex browser)"
- -DWITH_XC_FDOSECRETS=ON
- -DWITH_XC_KEESHARE="$(usex keeshare)"
- -DWITH_XC_NETWORKING="$(usex network)"
- -DWITH_XC_SSHAGENT=ON
- -DWITH_XC_UPDATECHECK=OFF
- -DWITH_XC_YUBIKEY="$(usex yubikey)"
- )
- if [[ "${PV}" == *_beta* ]] ; then
- mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
- fi
- cmake_src_configure
-}
diff --git a/app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild b/app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild
new file mode 100644
index 000000000000..6d17e534e3b4
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
+
+if [[ "${PV}" != *9999 ]] ; then
+ if [[ "${PV}" == *_beta* ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+
+ KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+ fi
+else
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+ [[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
+
+RDEPEND="
+ app-crypt/argon2:=
+ dev-libs/botan:3=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-gfx/qrencode:=
+ sys-libs/readline:0=
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
+ autotype? (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qttest:5
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-ruby/asciidoctor
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
+
+src_prepare() {
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-lto
+
+ local -a mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_DOCS="$(usex doc)"
+ -DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
+ -DWITH_XC_FDOSECRETS=ON
+ -DWITH_XC_KEESHARE="$(usex keeshare)"
+ -DWITH_XC_NETWORKING="$(usex network)"
+ -DWITH_XC_SSHAGENT=ON
+ -DWITH_XC_UPDATECHECK=OFF
+ -DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
+ )
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ fi
+ cmake_src_configure
+}
diff --git a/app-admin/keepassxc/keepassxc-2.7.8.ebuild b/app-admin/keepassxc/keepassxc-2.7.8.ebuild
new file mode 100644
index 000000000000..11cc2ac9b84e
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-2.7.8.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
+
+if [[ "${PV}" = *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="develop"
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+else
+ if [[ "${PV}" == *_beta* ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+ fi
+
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
+
+RDEPEND="
+ app-crypt/argon2:=
+ dev-libs/botan:3=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-gfx/qrencode:=
+ sys-libs/readline:0=
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
+ autotype? (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qttest:5
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-ruby/asciidoctor
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
+
+src_prepare() {
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-lto
+
+ local -a mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_DOCS="$(usex doc)"
+ -DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
+ -DWITH_XC_FDOSECRETS=ON
+ -DWITH_XC_KEESHARE="$(usex keeshare)"
+ -DWITH_XC_NETWORKING="$(usex network)"
+ -DWITH_XC_SSHAGENT=ON
+ -DWITH_XC_UPDATECHECK=OFF
+ -DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
+ )
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=(
+ -DOVERRIDE_VERSION="${PV/_/-}"
+ )
+ fi
+ cmake_src_configure
+}
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 0511c16e1277..11cc2ac9b84e 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -1,35 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
-HOMEPAGE="https://keepassxc.org"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
-if [[ "${PV}" != 9999 ]] ; then
+if [[ "${PV}" = *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="develop"
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+else
if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
else
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
fi
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
LICENSE="LGPL-2.1 GPL-2 GPL-3"
SLOT="0"
-IUSE="autotype browser ccache keeshare +network test yubikey"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
RDEPEND="
app-crypt/argon2:=
- dev-libs/libgcrypt:=
- >=dev-libs/libsodium-1.0.12:=
+ dev-libs/botan:3=
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -39,52 +45,69 @@ RDEPEND="
dev-qt/qtwidgets:5
media-gfx/qrencode:=
sys-libs/readline:0=
- sys-libs/zlib:=
- autotype? (
+ sys-libs/zlib:=[minizip]
+ X? (
dev-qt/qtx11extras:5
+ )
+ autotype? (
x11-libs/libX11
- x11-libs/libXi
x11-libs/libXtst
)
- keeshare? ( dev-libs/quazip )
- yubikey? ( sys-auth/ykpers )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
"
-
DEPEND="
${RDEPEND}
- dev-qt/linguist-tools:5
dev-qt/qttest:5
"
BDEPEND="
- ccache? ( dev-util/ccache )
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-ruby/asciidoctor
+ )
"
-RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
src_prepare() {
- use test || \
- sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
- cmake_src_prepare
+ cmake_src_prepare
}
src_configure() {
- local mycmakeargs=(
- -DWITH_CCACHE="$(usex ccache)"
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-lto
+
+ local -a mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
-DWITH_GUI_TESTS=OFF
-DWITH_TESTS="$(usex test)"
-DWITH_XC_AUTOTYPE="$(usex autotype)"
- -DWITH_XC_DOCS=OFF
+ -DWITH_XC_DOCS="$(usex doc)"
-DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
-DWITH_XC_FDOSECRETS=ON
-DWITH_XC_KEESHARE="$(usex keeshare)"
-DWITH_XC_NETWORKING="$(usex network)"
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_UPDATECHECK=OFF
-DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
)
if [[ "${PV}" == *_beta* ]] ; then
- mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ mycmakeargs+=(
+ -DOVERRIDE_VERSION="${PV/_/-}"
+ )
fi
cmake_src_configure
}
diff --git a/app-admin/keepassxc/metadata.xml b/app-admin/keepassxc/metadata.xml
index 0445305ebe59..dc74e3197e66 100644
--- a/app-admin/keepassxc/metadata.xml
+++ b/app-admin/keepassxc/metadata.xml
@@ -1,24 +1,27 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
- <use>
- <flag name="autotype">Add support to autotype the passwords into other applications</flag>
- <flag name="browser">Enables browser plugin support</flag>
- <flag name="ccache">Use <pkg>dev-util/ccache</pkg> to build keepassxc</flag>
- <flag name="keeshare">Enable KeeShare sharing integration</flag>
- <flag name="network">Enable network support</flag>
- <flag name="yubikey">Enable database unlocking via YubiKey.</flag>
- </use>
- <longdescription>
- KeePassXC provides a safe location for your passwords and similar
- data. It encrypts its databasee with AES either by passphrase or a key
- file, compatible with a PDA and Windows version.
- </longdescription>
- <upstream>
- <remote-id type="github">keepassxreboot/keepassxc</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <use>
+ <flag name="autotype">Add support to autotype the passwords into other applications</flag>
+ <flag name="browser">Enables browser plugin support</flag>
+ <flag name="keeshare">Enable KeeShare sharing integration</flag>
+ <flag name="network">Enable network support</flag>
+ <flag name="yubikey">Enable database unlocking via hardware keys supporting YubiKey-style HMAC-SHA1 protocol</flag>
+ </use>
+ <longdescription>
+ KeePassXC provides a safe location for your passwords and similar
+ data. It encrypts its databasee with AES either by passphrase or a key
+ file, compatible with a PDA and Windows version.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keepassxreboot/keepassxc</remote-id>
+ </upstream>
</pkgmetadata>