summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/Manifest4
-rw-r--r--app-admin/keepassxc/files/keepassxc-2.5.2-ccache_switch.patch59
-rw-r--r--app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch13
-rw-r--r--app-admin/keepassxc/keepassxc-2.5.3.ebuild97
-rw-r--r--app-admin/keepassxc/keepassxc-2.5.4.ebuild97
-rw-r--r--app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild110
-rw-r--r--app-admin/keepassxc/keepassxc-2.7.8.ebuild113
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild88
-rw-r--r--app-admin/keepassxc/metadata.xml45
9 files changed, 316 insertions, 310 deletions
diff --git a/app-admin/keepassxc/Manifest b/app-admin/keepassxc/Manifest
index 3701a4d91f13..40112daa3c5b 100644
--- a/app-admin/keepassxc/Manifest
+++ b/app-admin/keepassxc/Manifest
@@ -1,2 +1,2 @@
-DIST keepassxc-2.5.3-src.tar.xz 6839148 BLAKE2B b3cc32f9abb42e662edec0c28967fca65a4f3c794f70bfe6c40c39375cad8cbc35eba95431b33119268230a324f83f2e5a53186ee8fc64cd366e20eac1341dc5 SHA512 8b1e3360b4ae5de170be6936291f7b309de09b2462fcd5a48f239c22f1c8b6ffe721aca8d1e9b6ae3881f7b16374850d7f4b809733244fd16d45eed6ad4f60c6
-DIST keepassxc-2.5.4-src.tar.xz 6839396 BLAKE2B 5f7f415cab73c2665e3dff94c2bde039096b04a6e8e8a6ff4fe40d31cf4c6ff789f72d8c4c18ae0325c6db570933110a65348c4c359acadd2c89617435ffd6bd SHA512 8a70363dd579b95ccb05cb846aa34a5ed89de4305f3bef9e518e5986fe7f0313cb1daaa347f5b2267002f3fff4b71c87f5bb9073f6e6879d2556a2f0e4791dd3
+DIST keepassxc-2.7.7-src.tar.xz 9734460 BLAKE2B d94c42334bbfde46f14f4b14612f4297c500da76ba8a82de26c4a450ee1cacb9a15517a84ef445441651dc33a71f9ca7bca63bb04d0a4e8eeb0380eded6e5477 SHA512 fd82e377bf6e57623c65f2bdd463ea59c6465fbe009552e1030ce0fe9d9177fc448b7b36a90a0da9ed2a2ed161c017d13cef618ae785f89110c038e1d9396926
+DIST keepassxc-2.7.8-src.tar.xz 9764860 BLAKE2B edc5af2b7bd6173f8df4fa20fca54e78c40610d29b02ac9f9920382b8ead3ea293e22e578c353ffc1a374a23f1117a2595570d1de7053a1d36bcb40ed8eceb04 SHA512 c4767ced36d45855b83569d0fcbcfd384ef51d204dd703b006508d55cd7ac94ac36b5476f122fbe1dc6ec301a785e026722e8f0f961d5e339e10997a3871741a
diff --git a/app-admin/keepassxc/files/keepassxc-2.5.2-ccache_switch.patch b/app-admin/keepassxc/files/keepassxc-2.5.2-ccache_switch.patch
deleted file mode 100644
index 57d8b3d714ca..000000000000
--- a/app-admin/keepassxc/files/keepassxc-2.5.2-ccache_switch.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From ae471bea14c8e05bcf368168649399b116a69992 Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Tue, 7 Jan 2020 17:44:08 -0500
-Subject: [PATCH] CMakeLists.txt: Do not unconditionally use ccache
-
-This causes build failures in Gentoo because we don't allow access to ccache files if ccache is not enabled for build.
-
-Fix this by adding a WITH_CCACHE cmake option and change behavior so that cmake fails if WITH_CCACHE is enabled but ccache program cannot be found.
-
-Gentoo-bug: https://bugs.gentoo.org/704560
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- CMakeLists.txt | 19 ++++++++++++-------
- 1 file changed, 12 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c2f9b5bfe..1c5746c59 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -27,13 +27,6 @@ string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LOWER)
-
- set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
-
--# Use the Compiler Cache (ccache) if it is installed
--# (install with: sudo apt get ccache)
--find_program (CCACHE_FOUND ccache)
--if (CCACHE_FOUND)
-- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
--endif (CCACHE_FOUND)
--
- # Support Visual Studio Code
- include(CMakeToolsHelpers OPTIONAL)
- include(FeatureSummary)
-@@ -48,6 +41,7 @@ option(WITH_DEV_BUILD "Use only for development. Disables/warns about deprecated
- option(WITH_ASAN "Enable address sanitizer checks (Linux / macOS only)" OFF)
- option(WITH_COVERAGE "Use to build with coverage tests (GCC only)." OFF)
- option(WITH_APP_BUNDLE "Enable Application Bundle for macOS" ON)
-+option(WITH_CCACHE "Use ccache for build" OFF)
-
- set(WITH_XC_ALL OFF CACHE BOOL "Build in all available plugins")
-
-@@ -65,6 +59,17 @@ if(APPLE)
- option(WITH_XC_TOUCHID "Include TouchID support for macOS." OFF)
- endif()
-
-+if(WITH_CCACHE)
-+ # Use the Compiler Cache (ccache) program
-+ # (install with: sudo apt get ccache)
-+ find_program (CCACHE_FOUND ccache)
-+ if(CCACHE_FOUND)
-+ set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
-+ else()
-+ message(FATAL_ERROR "ccache requested but cannot be found.")
-+ endif()
-+endif()
-+
- if(WITH_XC_ALL)
- # Enable all options (except update check)
- set(WITH_XC_AUTOTYPE ON)
diff --git a/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch b/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch
new file mode 100644
index 000000000000..ccee26cb5ba9
--- /dev/null
+++ b/app-admin/keepassxc/files/keepassxc-2.7.4-tests.patch
@@ -0,0 +1,13 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -231,10 +231,6 @@ if(WITH_XC_BROWSER)
+ LIBS ${TEST_LIBRARIES})
+ endif()
+
+-add_unit_test(NAME testcli SOURCES TestCli.cpp
+- LIBS testsupport cli ${TEST_LIBRARIES})
+-target_compile_definitions(testcli PRIVATE KEEPASSX_CLI_PATH="$<TARGET_FILE:keepassxc-cli>")
+-
+ if(WITH_GUI_TESTS)
+ add_subdirectory(gui)
+ endif(WITH_GUI_TESTS)
diff --git a/app-admin/keepassxc/keepassxc-2.5.3.ebuild b/app-admin/keepassxc/keepassxc-2.5.3.ebuild
deleted file mode 100644
index fa1a828a2cc5..000000000000
--- a/app-admin/keepassxc/keepassxc-2.5.3.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
-HOMEPAGE="https://keepassxc.org"
-
-if [[ "${PV}" != 9999 ]] ; then
- if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${P/_/-}"
- else
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
- KEYWORDS="amd64 x86"
- fi
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
-fi
-
-LICENSE="LGPL-2.1 GPL-2 GPL-3"
-SLOT="0"
-IUSE="autotype browser ccache debug keeshare +network test yubikey"
-
-RDEPEND="
- app-crypt/argon2:=
- dev-libs/libgcrypt:=
- >=dev-libs/libsodium-1.0.12:=
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- media-gfx/qrencode:=
- sys-libs/readline:0=
- sys-libs/zlib:=
- autotype? (
- dev-qt/qtx11extras:5
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXtst
- )
- keeshare? ( dev-libs/quazip )
- yubikey? ( sys-auth/ykpers )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-qt/linguist-tools:5
- dev-qt/qttest:5
-"
-BDEPEND="
- ccache? ( dev-util/ccache )
-"
-# Not a runtime dependency but still needed (see bug #667092)
-PDEPEND="
- x11-misc/xsel
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.5.2-ccache_switch.patch"
-)
-
-src_prepare() {
- use test || \
- sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_CCACHE="$(usex ccache)"
- -DWITH_GUI_TESTS=OFF
- -DWITH_TESTS="$(usex test)"
- -DWITH_XC_AUTOTYPE="$(usex autotype)"
- -DWITH_XC_BROWSER="$(usex browser)"
- -DWITH_XC_FDOSECRETS=ON
- -DWITH_XC_KEESHARE="$(usex keeshare)"
- -DWITH_XC_NETWORKING="$(usex network)"
- -DWITH_XC_SSHAGENT=ON
- -DWITH_XC_UPDATECHECK=OFF
- -DWITH_XC_YUBIKEY="$(usex yubikey)"
- )
- if [[ "${PV}" == *_beta* ]] ; then
- mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
- fi
- cmake_src_configure
-}
diff --git a/app-admin/keepassxc/keepassxc-2.5.4.ebuild b/app-admin/keepassxc/keepassxc-2.5.4.ebuild
deleted file mode 100644
index 0930d877e6c9..000000000000
--- a/app-admin/keepassxc/keepassxc-2.5.4.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
-HOMEPAGE="https://keepassxc.org"
-
-if [[ "${PV}" != 9999 ]] ; then
- if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${P/_/-}"
- else
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
- fi
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
-fi
-
-LICENSE="LGPL-2.1 GPL-2 GPL-3"
-SLOT="0"
-IUSE="autotype browser ccache debug keeshare +network test yubikey"
-
-RDEPEND="
- app-crypt/argon2:=
- dev-libs/libgcrypt:=
- >=dev-libs/libsodium-1.0.12:=
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- media-gfx/qrencode:=
- sys-libs/readline:0=
- sys-libs/zlib:=
- autotype? (
- dev-qt/qtx11extras:5
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXtst
- )
- keeshare? ( dev-libs/quazip )
- yubikey? ( sys-auth/ykpers )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-qt/linguist-tools:5
- dev-qt/qttest:5
-"
-BDEPEND="
- ccache? ( dev-util/ccache )
-"
-# Not a runtime dependency but still needed (see bug #667092)
-PDEPEND="
- x11-misc/xsel
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.5.2-ccache_switch.patch"
-)
-
-src_prepare() {
- use test || \
- sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_CCACHE="$(usex ccache)"
- -DWITH_GUI_TESTS=OFF
- -DWITH_TESTS="$(usex test)"
- -DWITH_XC_AUTOTYPE="$(usex autotype)"
- -DWITH_XC_BROWSER="$(usex browser)"
- -DWITH_XC_FDOSECRETS=ON
- -DWITH_XC_KEESHARE="$(usex keeshare)"
- -DWITH_XC_NETWORKING="$(usex network)"
- -DWITH_XC_SSHAGENT=ON
- -DWITH_XC_UPDATECHECK=OFF
- -DWITH_XC_YUBIKEY="$(usex yubikey)"
- )
- if [[ "${PV}" == *_beta* ]] ; then
- mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
- fi
- cmake_src_configure
-}
diff --git a/app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild b/app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild
new file mode 100644
index 000000000000..6d17e534e3b4
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-2.7.7-r2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
+
+if [[ "${PV}" != *9999 ]] ; then
+ if [[ "${PV}" == *_beta* ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+
+ KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+ fi
+else
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+ [[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
+
+RDEPEND="
+ app-crypt/argon2:=
+ dev-libs/botan:3=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-gfx/qrencode:=
+ sys-libs/readline:0=
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
+ autotype? (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qttest:5
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-ruby/asciidoctor
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
+
+src_prepare() {
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-lto
+
+ local -a mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_DOCS="$(usex doc)"
+ -DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
+ -DWITH_XC_FDOSECRETS=ON
+ -DWITH_XC_KEESHARE="$(usex keeshare)"
+ -DWITH_XC_NETWORKING="$(usex network)"
+ -DWITH_XC_SSHAGENT=ON
+ -DWITH_XC_UPDATECHECK=OFF
+ -DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
+ )
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ fi
+ cmake_src_configure
+}
diff --git a/app-admin/keepassxc/keepassxc-2.7.8.ebuild b/app-admin/keepassxc/keepassxc-2.7.8.ebuild
new file mode 100644
index 000000000000..11cc2ac9b84e
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-2.7.8.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
+
+if [[ "${PV}" = *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="develop"
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+else
+ if [[ "${PV}" == *_beta* ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+ fi
+
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
+
+RDEPEND="
+ app-crypt/argon2:=
+ dev-libs/botan:3=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-gfx/qrencode:=
+ sys-libs/readline:0=
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
+ autotype? (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/qttest:5
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-ruby/asciidoctor
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
+
+src_prepare() {
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-lto
+
+ local -a mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_DOCS="$(usex doc)"
+ -DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
+ -DWITH_XC_FDOSECRETS=ON
+ -DWITH_XC_KEESHARE="$(usex keeshare)"
+ -DWITH_XC_NETWORKING="$(usex network)"
+ -DWITH_XC_SSHAGENT=ON
+ -DWITH_XC_UPDATECHECK=OFF
+ -DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
+ )
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=(
+ -DOVERRIDE_VERSION="${PV/_/-}"
+ )
+ fi
+ cmake_src_configure
+}
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 949cb61dc8aa..11cc2ac9b84e 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -1,35 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
-HOMEPAGE="https://keepassxc.org"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
-if [[ "${PV}" != 9999 ]] ; then
+if [[ "${PV}" = *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="develop"
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+else
if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
else
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
fi
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
LICENSE="LGPL-2.1 GPL-2 GPL-3"
SLOT="0"
-IUSE="autotype browser ccache debug keeshare +network test yubikey"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
RDEPEND="
app-crypt/argon2:=
- dev-libs/libgcrypt:=
- >=dev-libs/libsodium-1.0.12:=
+ dev-libs/botan:3=
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -39,55 +45,69 @@ RDEPEND="
dev-qt/qtwidgets:5
media-gfx/qrencode:=
sys-libs/readline:0=
- sys-libs/zlib:=
- autotype? (
+ sys-libs/zlib:=[minizip]
+ X? (
dev-qt/qtx11extras:5
+ )
+ autotype? (
x11-libs/libX11
- x11-libs/libXi
x11-libs/libXtst
)
- keeshare? ( dev-libs/quazip )
- yubikey? ( sys-auth/ykpers )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
"
-
DEPEND="
${RDEPEND}
- dev-qt/linguist-tools:5
dev-qt/qttest:5
"
BDEPEND="
- ccache? ( dev-util/ccache )
-"
-# Not a runtime dependency but still needed (see bug #667092)
-PDEPEND="
- x11-misc/xsel
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-ruby/asciidoctor
+ )
"
-RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
src_prepare() {
- use test || \
- sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
- cmake_src_prepare
+ cmake_src_prepare
}
src_configure() {
- local mycmakeargs=(
- -DWITH_CCACHE="$(usex ccache)"
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-lto
+
+ local -a mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
-DWITH_GUI_TESTS=OFF
-DWITH_TESTS="$(usex test)"
-DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_DOCS="$(usex doc)"
-DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
+ -DWITH_XC_BOTAN3=ON
-DWITH_XC_FDOSECRETS=ON
-DWITH_XC_KEESHARE="$(usex keeshare)"
-DWITH_XC_NETWORKING="$(usex network)"
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_UPDATECHECK=OFF
-DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
)
if [[ "${PV}" == *_beta* ]] ; then
- mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ mycmakeargs+=(
+ -DOVERRIDE_VERSION="${PV/_/-}"
+ )
fi
cmake_src_configure
}
diff --git a/app-admin/keepassxc/metadata.xml b/app-admin/keepassxc/metadata.xml
index 0445305ebe59..dc74e3197e66 100644
--- a/app-admin/keepassxc/metadata.xml
+++ b/app-admin/keepassxc/metadata.xml
@@ -1,24 +1,27 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
- <use>
- <flag name="autotype">Add support to autotype the passwords into other applications</flag>
- <flag name="browser">Enables browser plugin support</flag>
- <flag name="ccache">Use <pkg>dev-util/ccache</pkg> to build keepassxc</flag>
- <flag name="keeshare">Enable KeeShare sharing integration</flag>
- <flag name="network">Enable network support</flag>
- <flag name="yubikey">Enable database unlocking via YubiKey.</flag>
- </use>
- <longdescription>
- KeePassXC provides a safe location for your passwords and similar
- data. It encrypts its databasee with AES either by passphrase or a key
- file, compatible with a PDA and Windows version.
- </longdescription>
- <upstream>
- <remote-id type="github">keepassxreboot/keepassxc</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <use>
+ <flag name="autotype">Add support to autotype the passwords into other applications</flag>
+ <flag name="browser">Enables browser plugin support</flag>
+ <flag name="keeshare">Enable KeeShare sharing integration</flag>
+ <flag name="network">Enable network support</flag>
+ <flag name="yubikey">Enable database unlocking via hardware keys supporting YubiKey-style HMAC-SHA1 protocol</flag>
+ </use>
+ <longdescription>
+ KeePassXC provides a safe location for your passwords and similar
+ data. It encrypts its databasee with AES either by passphrase or a key
+ file, compatible with a PDA and Windows version.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keepassxreboot/keepassxc</remote-id>
+ </upstream>
</pkgmetadata>