summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/lnav/files')
-rw-r--r--app-admin/lnav/files/lnav-0.11.0-disable-tests.patch67
-rw-r--r--app-admin/lnav/files/lnav-0.11.1-0001-Fix-build-with-GCC-13-add-missing-cstdint-include.patch26
-rw-r--r--app-admin/lnav/files/lnav-0.8.4-disable-tests.patch18
-rw-r--r--app-admin/lnav/files/lnav-0.9.0-bug639332-tinfow.patch10
4 files changed, 93 insertions, 28 deletions
diff --git a/app-admin/lnav/files/lnav-0.11.0-disable-tests.patch b/app-admin/lnav/files/lnav-0.11.0-disable-tests.patch
new file mode 100644
index 000000000000..8aa000d30c63
--- /dev/null
+++ b/app-admin/lnav/files/lnav-0.11.0-disable-tests.patch
@@ -0,0 +1,67 @@
+From 70231dce88cf47f2f3e2b396fe0623ea74eeadfc Mon Sep 17 00:00:00 2001
+From: Randy Barlow <randy@electronsweatshop.com>
+Date: Sat, 3 Sep 2022 18:13:08 -0400
+Subject: [PATCH] Disable some flaky tests
+
+Certain tests commented out for stability reasons:
+ * listview: Fails when building inside sandbox
+ https://github.com/tstack/lnav/issues/1039
+ * mvattrline: Fails on some testers boxes. Documented here:
+ https://github.com/tstack/lnav/issues/911
+ * logfile: Flaky. Fails some times and not others. i.e. Race condition
+ * tui: Can hang the build
+
+Signed-off-by: Randy Barlow <randy@electronsweatshop.com>
+---
+ test/Makefile.am | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/test/Makefile.am b/test/Makefile.am
+index fd09a656..07d6758e 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -188,10 +188,7 @@ dist_noinst_SCRIPTS = \
+ test_grep_proc.sh \
+ test_json_format.sh \
+ test_line_buffer.sh \
+- test_listview.sh \
+- test_logfile.sh \
+ test_meta.sh \
+- test_mvwattrline.sh \
+ test_regex101.sh \
+ test_remote.sh \
+ test_scripts.sh \
+@@ -211,7 +208,6 @@ dist_noinst_SCRIPTS = \
+ test_sql_xml_func.sh \
+ test_sql_yaml_func.sh \
+ test_text_file.sh \
+- test_tui.sh \
+ test_view_colors.sh \
+ test_vt52_curses.sh \
+ test_pretty_print.sh
+@@ -391,14 +387,11 @@ TESTS = \
+ test_cmds.sh \
+ test_config.sh \
+ test_events.sh \
+- test_listview.sh \
+ test_meta.sh \
+- test_mvwattrline.sh \
+ test_grep_proc.sh \
+ test_grep_proc2 \
+ test_json_format.sh \
+ test_log_accel \
+- test_logfile.sh \
+ test_reltime \
+ test_scripts.sh \
+ test_sessions.sh \
+@@ -417,7 +410,6 @@ TESTS = \
+ test_sql_xml_func.sh \
+ test_sql_yaml_func.sh \
+ test_text_file.sh \
+- test_tui.sh \
+ test_data_parser.sh \
+ test_pretty_print.sh \
+ test_view_colors.sh \
+--
+2.37.2
+
diff --git a/app-admin/lnav/files/lnav-0.11.1-0001-Fix-build-with-GCC-13-add-missing-cstdint-include.patch b/app-admin/lnav/files/lnav-0.11.1-0001-Fix-build-with-GCC-13-add-missing-cstdint-include.patch
new file mode 100644
index 000000000000..0dffeeb9bdbb
--- /dev/null
+++ b/app-admin/lnav/files/lnav-0.11.1-0001-Fix-build-with-GCC-13-add-missing-cstdint-include.patch
@@ -0,0 +1,26 @@
+https://github.com/tstack/lnav/pull/1112
+
+From e25d3e3c69fcf57bbaec2333846b9a43c4d1fc90 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 21 Jan 2023 18:11:20 +0000
+Subject: [PATCH] Fix build with GCC 13 (add missing <cstdint> include)
+
+GCC 13 (as usual for new compiler releases) shuffles around some
+internal includes and so <cstdint> is no longer transitively included.
+
+Explicitly include <cstdint> for uint32_t.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/src/base/lnav_log.hh
++++ b/src/base/lnav_log.hh
+@@ -32,6 +32,7 @@
+ #ifndef lnav_log_hh
+ #define lnav_log_hh
+
++#include <cstdint>
+ #include <string>
+
+ #include <stdio.h>
+--
+2.39.1
+
diff --git a/app-admin/lnav/files/lnav-0.8.4-disable-tests.patch b/app-admin/lnav/files/lnav-0.8.4-disable-tests.patch
deleted file mode 100644
index 6b431c33b133..000000000000
--- a/app-admin/lnav/files/lnav-0.8.4-disable-tests.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- lnav-0.8.4/test/Makefile.am
-+++ lnav-0.8.4/test/Makefile.am
-@@ -373,7 +373,6 @@
- test_concise \
- test_line_buffer2 \
- test_line_buffer.sh \
-- test_listview.sh \
- test_meta.sh \
- test_grep_proc.sh \
- test_grep_proc2 \
-@@ -381,7 +380,6 @@
- test_json_op.sh \
- test_json_ptr_walk.sh \
- test_log_accel \
-- test_logfile.sh \
- test_pcrepp \
- test_reltime \
- test_scripts.sh \
diff --git a/app-admin/lnav/files/lnav-0.9.0-bug639332-tinfow.patch b/app-admin/lnav/files/lnav-0.9.0-bug639332-tinfow.patch
deleted file mode 100644
index 8399412f0cf1..000000000000
--- a/app-admin/lnav/files/lnav-0.9.0-bug639332-tinfow.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/m4/ax_with_curses.m4 2019-07-28 08:49:13.670014444 -0500
-+++ b/m4/ax_with_curses.m4 2019-07-28 08:46:32.280013473 -0500
-@@ -216,6 +216,8 @@
- ax_cv_curses=yes
- ax_cv_curses_which=ncursesw
- CURSES_LIB="-lncursesw"
-+ temp_lib=`echo $ax_saved_LIBS|sed 's/tinfo/tinfow/'`
-+ ax_saved_LIBS=$temp_lib
- AC_DEFINE([HAVE_NCURSESW], [1], [Define to 1 if the NcursesW library is present])
- AC_DEFINE([HAVE_CURSES], [1], [Define to 1 if a SysV or X/Open compatible Curses library is present])