summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/logrotate/logrotate-3.15.1.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.15.1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/app-admin/logrotate/logrotate-3.15.1.ebuild b/app-admin/logrotate/logrotate-3.15.1.ebuild
index ee5b360db5be..58b95631d2dc 100644
--- a/app-admin/logrotate/logrotate-3.15.1.ebuild
+++ b/app-admin/logrotate/logrotate-3.15.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit systemd
@@ -14,15 +14,15 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="acl +cron selinux"
-CDEPEND="
+COMMON_DEPEND="
>=dev-libs/popt-1.5
selinux? ( sys-libs/libselinux )
acl? ( virtual/acl )"
-DEPEND="${CDEPEND}
+DEPEND="${COMMON_DEPEND}
>=sys-apps/sed-4"
-RDEPEND="${CDEPEND}
+RDEPEND="${COMMON_DEPEND}
selinux? ( sec-policy/selinux-logrotate )
cron? ( virtual/cron )"
@@ -53,7 +53,10 @@ src_prepare() {
}
src_configure() {
- econf $(use_with acl) $(use_with selinux) --with-state-file-path="${STATEFILE}"
+ econf \
+ $(use_with acl) \
+ $(use_with selinux) \
+ --with-state-file-path="${STATEFILE}"
}
src_test() {