summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/logsentry')
-rw-r--r--app-admin/logsentry/logsentry-1.1.1-r3.ebuild (renamed from app-admin/logsentry/logsentry-1.1.1-r2.ebuild)47
-rw-r--r--app-admin/logsentry/metadata.xml2
2 files changed, 26 insertions, 23 deletions
diff --git a/app-admin/logsentry/logsentry-1.1.1-r2.ebuild b/app-admin/logsentry/logsentry-1.1.1-r3.ebuild
index 39ec1c755fc0..8676acdc4a74 100644
--- a/app-admin/logsentry/logsentry-1.1.1-r2.ebuild
+++ b/app-admin/logsentry/logsentry-1.1.1-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -9,24 +9,26 @@ DESCRIPTION="Automatically monitor system logs and mail security violations"
# Seems that the project has been discontinued by CISCO?
HOMEPAGE="https://sourceforge.net/projects/sentrytools/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
+S="${WORKDIR}"/logcheck-${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm ~mips ppc ~s390 sparc x86"
-IUSE=""
-
-DEPEND=">=sys-apps/sed-4"
-RDEPEND="virtual/mailx"
+IUSE="selinux"
-S="${WORKDIR}"/logcheck-${PV}
+RDEPEND="
+ virtual/mailx
+ selinux? ( sec-policy/selinux-logsentry )
+"
-src_compile() {
- einfo "compile and install mixed in the package makefile"
-}
+# compile and install mixed in the package makefile"
+src_compile() { :; }
src_install() {
dodir /usr/bin /var/tmp/logcheck /etc/logcheck
+
cp systems/linux/logcheck.sh{,.orig} || die
+
sed -i \
-e 's:/usr/local/bin:/usr/bin:' \
-e 's:/usr/local/etc:/etc/logcheck:' \
@@ -39,23 +41,24 @@ src_install() {
-e "s:/etc/logcheck/tmp:/var/tmp/logcheck:" \
-e "s:\$(CC):& \$(LDFLAGS):" \
Makefile || die "sed Makefile failed"
- make CC="$(tc-getCC)" CFLAGS="${CFLAGS}" linux || die
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" linux
dodoc README* CHANGES CREDITS
dodoc systems/linux/README.*
- cat << EOF > "${S}"/logsentry.cron || die
-#!/bin/sh
-#
-# Uncomment the following if you want
-# logsentry (logcheck) to run hourly
-#
-# this is part of the logsentry package
-#
-#
+ cat <<- EOF > "${S}"/logsentry.cron || die
+ #!/bin/sh
+ #
+ # Uncomment the following if you want
+ # logsentry (logcheck) to run hourly
+ #
+ # this is part of the logsentry package
+ #
+ #
-#/bin/sh /etc/logcheck/logcheck.sh
-EOF
+ #/bin/sh /etc/logcheck/logcheck.sh
+ EOF
exeinto /etc/cron.hourly
doexe logsentry.cron
diff --git a/app-admin/logsentry/metadata.xml b/app-admin/logsentry/metadata.xml
index 83faec9523ff..0abf7ed3f320 100644
--- a/app-admin/logsentry/metadata.xml
+++ b/app-admin/logsentry/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>