summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/longrun')
-rw-r--r--app-admin/longrun/Manifest2
-rw-r--r--app-admin/longrun/files/0.9-makefile_cflags.patch13
-rw-r--r--app-admin/longrun/files/0.9-replace-loff_t.patch35
-rw-r--r--app-admin/longrun/longrun-0.9-r4.ebuild70
-rw-r--r--app-admin/longrun/metadata.xml13
5 files changed, 0 insertions, 133 deletions
diff --git a/app-admin/longrun/Manifest b/app-admin/longrun/Manifest
deleted file mode 100644
index 15924ea63ff0..000000000000
--- a/app-admin/longrun/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST longrun-0.9.tar.bz2 11539 BLAKE2B a308dc7f350399da0bf593e2eee8109a90103b298d943976f0da143c52105362aa100763dcdd3cacd4c3244cdd5a7eb9a1b355aa803a69a2225ea18c6e5a60dd SHA512 6b38160f54d0cb9124c46c0e3ba22faf4ba4376ef58f7db40aabbab20836b1551dd839d28e5bf49540a5ce0e13312bd1d7332cc59ce45fa49f81d0b9746ef055
-DIST longrun_0.9-19.diff.gz 14697 BLAKE2B 98a7497679df5be0346a37b6119a9418c7fba80672eb2c345784628c3517c6f1fbc8d953abe2696a3b576310cd489e5c1d3595153bbfa9d82dfb44697c246116 SHA512 591519183017dd84d6f78554eea9f215be9346efc3f30889f5a25d01c6b68bd5a949507b9a0c871f9aca0b49e415c4fa261821d4158b24c93481394403b83e35
diff --git a/app-admin/longrun/files/0.9-makefile_cflags.patch b/app-admin/longrun/files/0.9-makefile_cflags.patch
deleted file mode 100644
index 8848dc667866..000000000000
--- a/app-admin/longrun/files/0.9-makefile_cflags.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2,8 +2,8 @@
-
- all: longrun README stamp-po
-
--longrun: longrun.c
-- gcc -DLOCALEDIR=\"$(LOCALEDIR)\" -g -O2 -W -Wall -o longrun longrun.c
-+CFLAGS += -W -Wall
-+CPPFLAGS += -DLOCALEDIR=\"$(LOCALEDIR)\"
-
- README: longrun.1
- groff -Tascii -man longrun.1 | col -bx > README
diff --git a/app-admin/longrun/files/0.9-replace-loff_t.patch b/app-admin/longrun/files/0.9-replace-loff_t.patch
deleted file mode 100644
index 589c0947b155..000000000000
--- a/app-admin/longrun/files/0.9-replace-loff_t.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Use off_t instead of loff_t. Both pread() and pwrite() take
-off_t not loff_t types. This breaks the build on musl. See
-
-https://bugs.gentoo.org/show_bug.cgi?id=541694
-
-diff -Naur longrun.orig/longrun.c longrun/longrun.c
---- longrun.orig/longrun.c 2015-03-07 19:05:19.166652462 +0000
-+++ longrun/longrun.c 2015-03-07 19:06:05.419651899 +0000
-@@ -181,7 +181,7 @@
- }
-
- /* note: if an output is NULL, then don't set it */
--void read_msr(loff_t address, int *lower, int *upper)
-+void read_msr(off_t address, int *lower, int *upper)
- {
- uint32_t data[2];
-
-@@ -193,7 +193,7 @@
- if (upper) *upper = data[1];
- }
-
--void write_msr(loff_t address, int lower, int upper)
-+void write_msr(off_t address, int lower, int upper)
- {
- uint32_t data[2];
-
-@@ -206,7 +206,7 @@
- }
-
- /* note: if an output is NULL, then don't set it */
--void read_cpuid(loff_t address, int *eax, int *ebx, int *ecx, int *edx)
-+void read_cpuid(off_t address, int *eax, int *ebx, int *ecx, int *edx)
- {
- uint32_t data[4];
-
diff --git a/app-admin/longrun/longrun-0.9-r4.ebuild b/app-admin/longrun/longrun-0.9-r4.ebuild
deleted file mode 100644
index 7992acb965bd..000000000000
--- a/app-admin/longrun/longrun-0.9-r4.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="A utility to control Transmeta's Crusoe and Efficeon processors"
-HOMEPAGE="http://freshmeat.net/projects/longrun/"
-
-DEBIAN_PATCH_VERSION="19"
-DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PATCH_VERSION}.diff"
-SRC_URI="
- https://www.kernel.org/pub/linux/utils/cpu/crusoe/${P}.tar.bz2
- mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-ppc x86"
-IUSE=""
-
-DEPEND="sys-apps/groff"
-
-S=${WORKDIR}/${PN}
-
-CONFIG_CHECK="~X86_MSR ~X86_CPUID"
-ERROR_X86_MSR="
-Longrun needs a MSR device to function. Please select
-MSR under Processor type and features. It can be build
-directly into the kernel or as a module."
-ERROR_X86_CPUID="
-Longrun needs a CPUID device to function. Please select
-CPUID under Processor type and features. It can be
-build directly into the kernel or as a module."
-
-PATCHES=(
- "${WORKDIR}"/${DEBIAN_PATCH}
- "${FILESDIR}"/${PV}-makefile_cflags.patch
- "${FILESDIR}"/${PV}-replace-loff_t.patch
-)
-
-src_configure() {
- tc-export CC
-}
-
-src_install() {
- default
- dodoc MAKEDEV-cpuid-msr
-}
-
-pkg_postinst() {
- if linux_config_exists; then
- if linux_chkconfig_module X86_MSR; then
- elog "You have compiled MSR as a module."
- elog "You need to load it before using Longrun."
- elog "The module is called msr."
- elog
- fi
-
- if linux_chkconfig_module X86_CPUID; then
- elog "You have compiled CPUID as a module."
- elog "You need to load it before using Longrun."
- elog "The module is called cpuid."
- fi
- else
- elog "You have no kernel configuration available."
- elog "Longrun needs both CPUID and MSR capabilites,"
- elog "in the kernel you intend to run it under."
- fi
-}
diff --git a/app-admin/longrun/metadata.xml b/app-admin/longrun/metadata.xml
deleted file mode 100644
index fcfeedac0c13..000000000000
--- a/app-admin/longrun/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>
- Longrun is a user space utility program for controlling the Longrun
- thermal and power save functionalities found in the processors made
- by Transmeta.
- </longdescription>
- <upstream>
- <remote-id type="freshmeat">longrun</remote-id>
- </upstream>
-</pkgmetadata>