summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/needrestart/needrestart-9999.ebuild')
-rw-r--r--app-admin/needrestart/needrestart-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-admin/needrestart/needrestart-9999.ebuild b/app-admin/needrestart/needrestart-9999.ebuild
index 631c9ffd80dd..c773506fddc2 100644
--- a/app-admin/needrestart/needrestart-9999.ebuild
+++ b/app-admin/needrestart/needrestart-9999.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/liske/${PN}.git"
inherit git-r3
SRC_URI=""
- KEYWORDS=""
else
SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
DESCRIPTION="Restart daemons after library updates"
@@ -29,7 +28,8 @@ RDEPEND="
dev-perl/Sort-Naturally
dev-perl/TermReadKey
sys-apps/init-system-helpers
- sys-apps/iucode_tool
+ amd64? ( sys-apps/iucode_tool )
+ x86? ( sys-apps/iucode_tool )
"
DEPEND="${RDEPEND}
sys-devel/gettext