summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ngxtop')
-rw-r--r--app-admin/ngxtop/metadata.xml2
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.3_pre141201-r3.ebuild (renamed from app-admin/ngxtop/ngxtop-0.0.3_pre141201-r1.ebuild)18
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.3_pre141201.ebuild28
3 files changed, 9 insertions, 39 deletions
diff --git a/app-admin/ngxtop/metadata.xml b/app-admin/ngxtop/metadata.xml
index 9d2ded372d85..f840f4bd7a05 100644
--- a/app-admin/ngxtop/metadata.xml
+++ b/app-admin/ngxtop/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
<email>hydrapolic@gmail.com</email>
diff --git a/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r1.ebuild b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r3.ebuild
index 31b0ab02bf84..873152bf9eb5 100644
--- a/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r1.ebuild
+++ b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite"
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -14,16 +14,14 @@ HOMEPAGE="https://github.com/lebinh/ngxtop"
#SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
-SLOT="0"
LICENSE="MIT"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-RDEPEND="
- dev-python/docopt[${PYTHON_USEDEP}]
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-"
PATCHES=( "${FILESDIR}"/${PN}-0.0.2-py3.patch )
+
+distutils_enable_tests pytest
diff --git a/app-admin/ngxtop/ngxtop-0.0.3_pre141201.ebuild b/app-admin/ngxtop/ngxtop-0.0.3_pre141201.ebuild
deleted file mode 100644
index 1b32811c6b60..000000000000
--- a/app-admin/ngxtop/ngxtop-0.0.3_pre141201.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{7,8} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="real-time metrics for nginx server (and others)"
-HOMEPAGE="https://github.com/lebinh/ngxtop"
-#SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- dev-python/docopt[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/tabulate[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.0.2-py3.patch )