summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/op-cli-bin/op-cli-bin-1.12.3.ebuild')
-rw-r--r--app-admin/op-cli-bin/op-cli-bin-1.12.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-admin/op-cli-bin/op-cli-bin-1.12.3.ebuild b/app-admin/op-cli-bin/op-cli-bin-1.12.3.ebuild
new file mode 100644
index 000000000000..1e1b0736b834
--- /dev/null
+++ b/app-admin/op-cli-bin/op-cli-bin-1.12.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command line interface for the 1password password manager"
+HOMEPAGE="https://1password.com/downloads/command-line/"
+SITE="https://cache.agilebits.com/dist/1P/op/pkg/v${PV}/"
+SRC_URI="${SITE}/op_linux_amd64_v${PV}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-arch/unzip"
+
+QA_PREBUILT="usr/bin/op"
+RESTRICT="bindist mirror"
+S="${WORKDIR}"
+
+src_install() {
+ dobin op
+}