summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pass-otp/pass-otp-1.1.0.ebuild')
-rw-r--r--app-admin/pass-otp/pass-otp-1.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-admin/pass-otp/pass-otp-1.1.0.ebuild b/app-admin/pass-otp/pass-otp-1.1.0.ebuild
new file mode 100644
index 000000000000..40e37ea67994
--- /dev/null
+++ b/app-admin/pass-otp/pass-otp-1.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A pass extension for managing one-time-password (OTP) tokens."
+HOMEPAGE="https://github.com/tadfisher/pass-otp"
+SRC_URI="https://github.com/tadfisher/pass-otp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qrcode test"
+
+DEPEND="test? ( dev-tcltk/expect:* )"
+
+RDEPEND=">=app-admin/pass-1.7
+ sys-auth/oath-toolkit
+ qrcode? ( media-gfx/qrencode )"
+
+src_compile() {
+ :
+}