summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pass')
-rw-r--r--app-admin/pass/Manifest1
-rw-r--r--app-admin/pass/metadata.xml7
-rw-r--r--app-admin/pass/pass-1.7.3-r2.ebuild79
-rw-r--r--app-admin/pass/pass-1.7.4-r2.ebuild (renamed from app-admin/pass/pass-1.7.3.ebuild)28
-rw-r--r--app-admin/pass/pass-9999.ebuild43
5 files changed, 124 insertions, 34 deletions
diff --git a/app-admin/pass/Manifest b/app-admin/pass/Manifest
index f12d405e6d6a..09d1fa948898 100644
--- a/app-admin/pass/Manifest
+++ b/app-admin/pass/Manifest
@@ -1 +1,2 @@
DIST password-store-1.7.3.tar.xz 63416 BLAKE2B 5931608e0208dfe6965b79f586c153a4930d1c3d3b74433d026ee0bc5889fcc29334c637ca4fb68308d0169bad7c8235b6632e9f80eda1e24f0f5721353f88e3 SHA512 89755a7b02f05d75055a9fc14fd3f456c0a49ec31bdffd097a027f91228c64a98b18c1e80017aeda811773ae3287ff1b9737532da8ded06799d8fe3979ca06f7
+DIST password-store-1.7.4.tar.xz 65272 BLAKE2B db1a34b5900802731deaf09d3ade1d3f00022fd21eb0b21140dca3d399c89183dc901e5bce15d7bb6041e62017e2b8b6df61c6ec3eadb1df6c0278dbc6c2bc11 SHA512 1fe108895b224451b54e545d399b6a97040e094049448509f92ae33164a5cf9044a91f52edfc705fcf333f6526df1a478deeebc4df109764d58100f9e3e22681
diff --git a/app-admin/pass/metadata.xml b/app-admin/pass/metadata.xml
index 3e292a92eba7..5d4842c01b3c 100644
--- a/app-admin/pass/metadata.xml
+++ b/app-admin/pass/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>zx2c4@gentoo.org</email>
@@ -12,11 +12,8 @@
<flag name="git">
Use <pkg>dev-vcs/git</pkg> for password revisions.
</flag>
- <flag name="fish-completion">
- Enable fish completion support.
- </flag>
<flag name="dmenu">
- Add support for x11-misc/dmenu with the 'passmenu' program.
+ Add support for <pkg>x11-misc/dmenu</pkg> with the 'passmenu' program.
</flag>
<flag name="importers">
Allow importing passwords from other password managers using various contributed scripts.
diff --git a/app-admin/pass/pass-1.7.3-r2.ebuild b/app-admin/pass/pass-1.7.3-r2.ebuild
new file mode 100644
index 000000000000..1a8952ad9f5b
--- /dev/null
+++ b/app-admin/pass/pass-1.7.3-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 elisp-common
+
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
+HOMEPAGE="https://www.passwordstore.org/"
+SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
+S="${WORKDIR}/password-store-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
+IUSE="+git X emacs dmenu importers"
+
+RDEPEND="
+ app-crypt/gnupg
+ media-gfx/qrencode[png(+)]
+ >=app-text/tree-1.7.0
+ git? ( dev-vcs/git )
+ X? ( x11-misc/xclip )
+ elibc_Darwin? ( app-misc/getopt )
+ dmenu? ( x11-misc/dmenu x11-misc/xdotool )
+ emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
+"
+
+src_prepare() {
+ default
+
+ use elibc_Darwin || return
+
+ # use coreutils
+ sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
+ # host getopt isn't cool, and we aren't brew (rip out brew reference)
+ sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
+ # make sure we can find "mount"
+ sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
+}
+
+src_compile() {
+ use emacs && elisp-compile contrib/emacs/*.el
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ BASHCOMPDIR="$(get_bashcompdir)" \
+ WITH_BASHCOMP=yes \
+ WITH_ZSHCOMP=yes \
+ WITH_FISHCOMP=yes
+
+ use dmenu && dobin contrib/dmenu/passmenu
+
+ if use emacs; then
+ elisp-install ${PN} contrib/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ fi
+
+ if use importers; then
+ exeinto /usr/share/${PN}/importers
+ doexe contrib/importers/*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use importers; then
+ einfo "To import passwords from other password managers, you may use the"
+ einfo "various importer scripts found in:"
+ einfo " ${EROOT}/usr/share/${PN}/importers/"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-admin/pass/pass-1.7.3.ebuild b/app-admin/pass/pass-1.7.4-r2.ebuild
index 0f7ca8dcb1a8..a70dea5f4464 100644
--- a/app-admin/pass/pass-1.7.3.ebuild
+++ b/app-admin/pass/pass-1.7.4-r2.ebuild
@@ -1,38 +1,37 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit bash-completion-r1 elisp-common
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
+S="${WORKDIR}/password-store-${PV}"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+IUSE="+git wayland X emacs dmenu importers"
RDEPEND="
app-crypt/gnupg
- media-gfx/qrencode
+ media-gfx/qrencode[png(+)]
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
+ wayland? ( gui-apps/wl-clipboard )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
- zsh-completion? ( app-shells/gentoo-zsh-completions )
- fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
-S="${WORKDIR}/password-store-${PV}"
-
src_prepare() {
default
use elibc_Darwin || return
+
# use coreutils'
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
# host getopt isn't cool, and we aren't brew (rip out brew reference)
@@ -51,13 +50,16 @@ src_install() {
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
- WITH_ZSHCOMP=$(usex zsh-completion) \
- WITH_FISHCOMP=$(usex fish-completion)
+ WITH_ZSHCOMP=yes \
+ WITH_FISHCOMP=yes
+
use dmenu && dobin contrib/dmenu/passmenu
+
if use emacs; then
elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
+
if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
@@ -69,7 +71,7 @@ pkg_postinst() {
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
- einfo " ${EROOT%/}/usr/share/${PN}/importers/"
+ einfo " ${EROOT}/usr/share/${PN}/importers/"
fi
}
diff --git a/app-admin/pass/pass-9999.ebuild b/app-admin/pass/pass-9999.ebuild
index 9f6082612879..0fd8dcb77e6b 100644
--- a/app-admin/pass/pass-9999.ebuild
+++ b/app-admin/pass/pass-9999.ebuild
@@ -1,33 +1,41 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit bash-completion-r1 git-r3 elisp-common
+inherit bash-completion-r1 elisp-common
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://git.zx2c4.com/password-store"
+ inherit git-r3
+else
+ SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
+ S="${WORKDIR}/password-store-${PV}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+fi
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
-EGIT_REPO_URI="https://git.zx2c4.com/password-store"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS=""
-IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
+SLOT="0"
+IUSE="+git wayland X emacs dmenu importers"
RDEPEND="
app-crypt/gnupg
- media-gfx/qrencode
+ media-gfx/qrencode[png(+)]
>=app-text/tree-1.7.0
git? ( dev-vcs/git )
+ wayland? ( gui-apps/wl-clipboard )
X? ( x11-misc/xclip )
elibc_Darwin? ( app-misc/getopt )
- zsh-completion? ( app-shells/gentoo-zsh-completions )
- fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
- emacs? ( >=app-editors/emacs-23.1:* )
+ emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
src_prepare() {
+ default
+
use elibc_Darwin || return
# use coreutils'
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
@@ -38,7 +46,7 @@ src_prepare() {
}
src_compile() {
- :;
+ use emacs && elisp-compile contrib/emacs/*.el
}
src_install() {
@@ -47,13 +55,16 @@ src_install() {
PREFIX="${EPREFIX}/usr" \
BASHCOMPDIR="$(get_bashcompdir)" \
WITH_BASHCOMP=yes \
- WITH_ZSHCOMP=$(usex zsh-completion) \
- WITH_FISHCOMP=$(usex fish-completion)
+ WITH_ZSHCOMP=yes \
+ WITH_FISHCOMP=yes
+
use dmenu && dobin contrib/dmenu/passmenu
+
if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el
+ elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
+
if use importers; then
exeinto /usr/share/${PN}/importers
doexe contrib/importers/*
@@ -65,7 +76,7 @@ pkg_postinst() {
if use importers; then
einfo "To import passwords from other password managers, you may use the"
einfo "various importer scripts found in:"
- einfo " ${EROOT%/}/usr/share/${PN}/importers/"
+ einfo " ${EROOT}/usr/share/${PN}/importers/"
fi
}