summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/passwordsafe/passwordsafe-1.15.0.ebuild')
-rw-r--r--app-admin/passwordsafe/passwordsafe-1.15.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/app-admin/passwordsafe/passwordsafe-1.15.0.ebuild b/app-admin/passwordsafe/passwordsafe-1.15.0.ebuild
index bc3fbce0c6ee..43dc7b3551fa 100644
--- a/app-admin/passwordsafe/passwordsafe-1.15.0.ebuild
+++ b/app-admin/passwordsafe/passwordsafe-1.15.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
WX_GTK_VER="3.0-gtk3"
-inherit cmake desktop flag-o-matic optfeature wxwidgets xdg
+inherit cmake desktop optfeature wxwidgets xdg
MY_PV="${PV/_beta/BETA}"
DESCRIPTION="Password manager with wxGTK based frontend"
@@ -39,13 +39,9 @@ S="${WORKDIR}/pwsafe-${MY_PV}"
PATCHES=(
"${FILESDIR}"/${PN}-1.15.0-gcc12-time.patch
+ "${FILESDIR}"/${PN}-1.15.0-gtest-no-gnu++11.patch
)
-pkg_pretend() {
- einfo "Checking for -std=c++11 support in compiler"
- test-flags-CXX -std=c++11 > /dev/null || die
-}
-
src_configure() {
setup-wxwidgets