summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ps_mem/ps_mem-3.13_p20200417.ebuild')
-rw-r--r--app-admin/ps_mem/ps_mem-3.13_p20200417.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/ps_mem/ps_mem-3.13_p20200417.ebuild b/app-admin/ps_mem/ps_mem-3.13_p20200417.ebuild
new file mode 100644
index 000000000000..738db1ad89cc
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.13_p20200417.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 vcs-snapshot
+
+COMMIT="fc75a8cc3cda05c53a4ae4fe296deeb9fc43908d"
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/ps_mem"
+SRC_URI="https://github.com/pixelb/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}