summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/redfishtool/redfishtool-1.1.8.ebuild')
-rw-r--r--app-admin/redfishtool/redfishtool-1.1.8.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-admin/redfishtool/redfishtool-1.1.8.ebuild b/app-admin/redfishtool/redfishtool-1.1.8.ebuild
new file mode 100644
index 000000000000..4c2064451254
--- /dev/null
+++ b/app-admin/redfishtool/redfishtool-1.1.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and command-line tool for accessing the Redfish API"
+HOMEPAGE="https://github.com/DMTF/Redfishtool"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"