summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/redfishtool')
-rw-r--r--app-admin/redfishtool/Manifest1
-rw-r--r--app-admin/redfishtool/metadata.xml12
-rw-r--r--app-admin/redfishtool/redfishtool-1.1.8.ebuild21
3 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/redfishtool/Manifest b/app-admin/redfishtool/Manifest
new file mode 100644
index 000000000000..7634202c1d56
--- /dev/null
+++ b/app-admin/redfishtool/Manifest
@@ -0,0 +1 @@
+DIST redfishtool-1.1.8.tar.gz 83028 BLAKE2B 376d7513776aaf72bdc249d27312f25134c16ede12584ce334d7f89b07fc2abd986baa775fbc5f497d0679fba6997d5f908062af32186364b6609625fcb6e0c5 SHA512 c9aee7461013144e7d2ba2825f750cca52270cd658bb07e65764923c0ba489ec1e8a5ecb12a1b4f43ef8c0227fbe195a6869c2ae264ed778a5dddc513cbaa542
diff --git a/app-admin/redfishtool/metadata.xml b/app-admin/redfishtool/metadata.xml
new file mode 100644
index 000000000000..18acf7851c64
--- /dev/null
+++ b/app-admin/redfishtool/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">redfishtool</remote-id>
+ <remote-id type="github">DMTF/Redfishtool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/redfishtool/redfishtool-1.1.8.ebuild b/app-admin/redfishtool/redfishtool-1.1.8.ebuild
new file mode 100644
index 000000000000..4c2064451254
--- /dev/null
+++ b/app-admin/redfishtool/redfishtool-1.1.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and command-line tool for accessing the Redfish API"
+HOMEPAGE="https://github.com/DMTF/Redfishtool"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"