summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ryzen_monitor/ryzen_monitor-1.0.4.ebuild')
-rw-r--r--app-admin/ryzen_monitor/ryzen_monitor-1.0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/ryzen_monitor/ryzen_monitor-1.0.4.ebuild b/app-admin/ryzen_monitor/ryzen_monitor-1.0.4.ebuild
new file mode 100644
index 000000000000..9ac20aa45272
--- /dev/null
+++ b/app-admin/ryzen_monitor/ryzen_monitor-1.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+SRC_URI="https://github.com/hattedsquirrel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Monitor power information of Ryzen processors via the PM table of the SMU "
+HOMEPAGE="https://github.com/hattedsquirrel/ryzen_monitor"
+
+SLOT="0"
+LICENSE="AGPL-3"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-admin/ryzen_smu"
+
+PATCHES=(
+ "${FILESDIR}"/CFLAGS_override_fix.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/ryzen_monitor
+}