summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sshguard/sshguard-2.0.99.ebuild')
-rw-r--r--app-admin/sshguard/sshguard-2.0.99.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/sshguard/sshguard-2.0.99.ebuild b/app-admin/sshguard/sshguard-2.0.99.ebuild
new file mode 100644
index 000000000000..1e45c36ba086
--- /dev/null
+++ b/app-admin/sshguard/sshguard-2.0.99.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="http://sshguard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+DEPEND="
+ sys-devel/flex
+"
+RDEPEND="
+ virtual/logger
+"
+DOCS=(
+ CHANGELOG.rst
+ CONTRIBUTING.rst
+ README.rst
+ examples/net.sshguard.plist
+ examples/sshguard.service
+ examples/whitelistfile.example
+)
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ insinto /etc
+ newins examples/sshguard.conf.sample sshguard.conf
+}