summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sshguard/sshguard-99999.ebuild')
-rw-r--r--app-admin/sshguard/sshguard-99999.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/app-admin/sshguard/sshguard-99999.ebuild b/app-admin/sshguard/sshguard-99999.ebuild
index 0f9a63205b67..ee4653a215e3 100644
--- a/app-admin/sshguard/sshguard-99999.ebuild
+++ b/app-admin/sshguard/sshguard-99999.ebuild
@@ -1,16 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools git-r3
+inherit autotools systemd
DESCRIPTION="protects hosts from brute force attacks against ssh"
HOMEPAGE="https://www.sshguard.net/"
-EGIT_REPO_URI="https://bitbucket.org/${PN}/${PN}"
+
+if [[ "${PV}" == 99999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://bitbucket.org/${PN}/${PN}"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
DEPEND="
sys-devel/flex
@@ -23,15 +29,18 @@ DOCS=(
CONTRIBUTING.rst
README.rst
examples/net.sshguard.plist
- examples/sshguard.service
examples/whitelistfile.example
)
+
PATCHES=(
- "${FILESDIR}"/${PN}-2.1.0-conf.patch
+ "${FILESDIR}"/${PN}-2.4.1-conf.patch
)
src_prepare() {
default
+ sed -i -e "/ExecStartPre/s:/usr/sbin:/sbin:g" \
+ -e "/ExecStart/s:/usr/local/sbin:/usr/sbin:g" \
+ "${S}"/examples/${PN}.service || die
eautoreconf
}
@@ -43,4 +52,6 @@ src_install() {
insinto /etc
newins examples/sshguard.conf.sample sshguard.conf
+
+ systemd_dounit "${S}"/examples/sshguard.service
}